Bug 605159 - "Error: Illegal entry in bfrange block in ToUnicode CMap" messages when using xpdf
"Error: Illegal entry in bfrange block in ToUnicode CMap" messages when using...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xpdf (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 06:40 EDT by Andre Robatino
Modified: 2011-08-30 21:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: xpdf-3.03-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 16:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2010-06-17 06:40:53 EDT
Description of problem:
Certain PDF files generate lots of "Error: Illegal entry in bfrange block in ToUnicode CMap" messages when viewed with  xpdf.  This bug was originally reported against F12's evince (bug #574964) but then observed that it happens with xpdf as well.  The same happens in F13.  In Rawhide, it still happens with xpdf, but not with evince (the Rawhide version of evince is higher than F13's version, but the versions of xpdf are the same).  The attachment in the other bug works to reproduce this (https://bugzilla.redhat.com/attachment.cgi?id=401142).  You have to space forward to page 5 before the error messages appear.  I mostly see it when using Firefox and printing a web page to a PS file, then converting it to PDF with ps2pdf (the generated PDF file seems to be smaller this way than when saving to PDF directly).

Version-Release number of selected component (if applicable):
xpdf-3.02-15.fc13.x86_64

How reproducible:
always
Comment 1 Bug Zapper 2010-07-30 08:09:16 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2011-08-22 15:06:55 EDT
xpdf-3.03-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xpdf-3.03-1.fc15
Comment 3 Fedora Update System 2011-08-22 15:07:12 EDT
xpdf-3.03-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xpdf-3.03-1.fc14
Comment 4 Fedora Update System 2011-08-22 15:07:28 EDT
xpdf-3.03-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/xpdf-3.03-1.fc16
Comment 5 Fedora Update System 2011-08-23 00:29:27 EDT
Package xpdf-3.03-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xpdf-3.03-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xpdf-3.03-1.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-08-30 16:46:42 EDT
xpdf-3.03-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2011-08-30 21:35:06 EDT
xpdf-3.03-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2011-08-30 21:39:01 EDT
xpdf-3.03-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.