Bug 60516 - UPS not shut off when /usr not on root partition
Summary: UPS not shut off when /usr not on root partition
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nut   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-28 21:28 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 15:40:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-02-28 21:28:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98; Q312461)

Description of problem:
When power fails and battery level goes low, nut initiates a forced shutdown, 
but the UPS power to the computer is not turned off.  I have /usr mounted on a 
separate partition from /.  See "Additional Information" for a specific 
diagnosis.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure computer so that /usr is a different filesystem from /
2. Unplug the UPS and wait for battery level to go critical
3.
	

Actual Results:  Forced shut down is initiated, but UPS continues to supply 
power to the computer (as evidenced by lighted LED in the back of the computer).

Expected Results:  Forced shut down is initiated, and the UPS turns off the 
power to the computer (LED light goes out).

Additional info:

I am using the belkin model on /dev/ttyS0. So, $MODEL is "belkin" and $DEVICE 
is "/dev/ttyS0".
The reason for this problem is that nut UPS hardware drivers are installed 
in /usr/bin.  Near the end of the /etc/rc.d/init.d/halt script, the script 
executes $MODEL -k $DEVICE at a point when only the / and /proc filesystems are 
mounted.  At this point /usr has been dismounted.  So the shell cannot find the 
$MODEL command and the UPS is never turned off.  An easy workaround is to 
copy /usr/bin/belkin (or whatever model the user needs) to /bin/belkin.  
Eventually, all of the nut device drivers should be moved from /usr/bin to /bin 
(or /sbin).

Comment 1 Ngo Than 2002-06-02 15:02:31 UTC
It's fixed in 0.45.4-3. You will find it in rawhide


Note You need to log in before you can comment on or make changes to this bug.