Bug 605172 - rpm error during upgrade rising "ValueError: too many values to unpack"
rpm error during upgrade rising "ValueError: too many values to unpack"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Radek Vykydal
Release Test Team
:
: 612802 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 07:00 EDT by Radek Vykydal
Modified: 2010-11-10 14:48 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.21.53-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 567878
Environment:
Last Closed: 2010-11-10 14:48:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Vykydal 2010-06-17 07:00:38 EDT
+++ This bug was initially created as a clone of Bug #567878 +++

The following was filed automatically by anaconda:
anaconda 13.29 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 236, in callback
ValueError: too many values to unpack

--- Additional comment from fedora@shmuelhome.mine.nu on 2010-02-24 03:00:20 EST ---

Created an attachment (id=395934)
Attached traceback automatically from anaconda.

--- Additional comment from fedora@shmuelhome.mine.nu on 2010-02-24 06:53:10 EST ---

I don't know why this is reported as Fedora 12. This comes from trying to install the alpha rc2 of fedora 13.

--- Additional comment from jlaska@redhat.com on 2010-02-24 08:26:26 EST ---

I get the same thing when attempting to upgrade from a minimal F-12 system using F-13-Alpha-RC2.  I also see a failure while attempting to present the error handling dialog.  I've opened that against python-meh (see bug#567963)

13:10:35 Please manually connect your vnc client to test1247.test.redhat.com:1 (10.10.10.247) to begin the install.
Press <enter> for a shell
13:10:36 Starting graphical installation.
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/meh/handler.py", line 162, in <lambda>
  File "/usr/lib/python2.6/site-packages/meh/handler.py", line 107, in handleException
  File "/usr/lib/anaconda/gui.py", line 1085, in mainExceptionWindow
ImportError: No module named ui.gui

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/anaconda/yuminstall.py", line 236, in callback
ValueError: too many values to unpack
error: python callback <bound method AnacondaCallback.callback of <yuminstall.AnacondaCallback instance at 0x7fde1da12518>> failed, aborting!
/mnt/sysimage/var/lib/rpm: No such file or directory
/mnt/sysimage/var/lib/rpm: No such file or directory
install exited abnormally [1/1] 
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

--- Additional comment from clumens@redhat.com on 2010-02-24 09:40:33 EST ---

Can someone attach the syslog to this bug report?

--- Additional comment from jlaska@redhat.com on 2010-02-24 11:14:25 EST ---

Created an attachment (id=396093)
/tmp/*log.tgz

-rw-r--r-- root/root     11475 2010-02-24 11:11 tmp/anaconda.log
-rw-r--r-- root/root      3410 2010-02-24 11:12 tmp/minimon.log
-rw-r--r-- root/root     18767 2010-02-24 11:08 tmp/program.log
-rw-r--r-- root/root     61165 2010-02-24 11:12 tmp/storage.log
-rw-r--r-- root/root     42578 2010-02-24 11:12 tmp/syslog
-rwxr-xr-x root/root       880 2010-02-24 11:03 tmp/vncserver.log
-rw-r--r-- root/root      2459 2010-02-24 11:08 tmp/yum.log

--- Additional comment from jlaska@redhat.com on 2010-02-24 12:58:53 EST ---

While upgrades are not listed in the F-13-Alpha release criteria (https://fedoraproject.org/wiki/Fedora_13_Alpha_Release_Criteria), I suspect many people will attempt upgrades.  Adding keyword CommonBugs so adamw or I can document this issue for F-13-Alpha testers.

--- Additional comment from fedora@shmuelhome.mine.nu on 2010-02-24 13:33:55 EST ---

In my case, this was very serious and should be avoided by alpha testers who don't have a throw away configuration. Upon rebooting, I had a configuration which wouldn't run. It has a very bad mixture of f12 and f13 components, over 300 dupes including kernel-PAE, fedora-release, gcc and cpp. Package-cleanup wants to delete too much so this is going to have to be cleaned by hand. I would strongly advise people to avoid upgrading until this is fixed.

--- Additional comment from clumens@redhat.com on 2010-02-24 14:33:51 EST ---

Looking at:

http://git.fedorahosted.org/git/?p=anaconda.git;a=blob;f=yuminstall.py;hb=HEAD#l233

You see that this only occurs on a couple cases in the RPM callback - all errors.  In testing, I hit this case a couple times during one upgrade.  The first time during package installation, h was a tuple like we're expecting.  The second time it happened is post-installation, I believe after rpm.RPM_CALLBACK_UNINST_START/STOP has been seen in the above case.  This second time through, h is the string "cyrus-sasl".

Any idea what's going on here?  Shouldn't we be getting the same type as argument in all cases?

--- Additional comment from james.antill@redhat.com on 2010-02-24 16:10:26 EST ---

Chris, this is "normal" for rpm, we have a bunch of code in yum to handle it now Eg.:

http://yum.baseurl.org/gitweb?p=yum.git;a=commitdiff;h=cf5765f74a23229abcc26b4e4cf5563b4d2cfeb6

--- Additional comment from clumens@redhat.com on 2010-02-24 16:43:12 EST ---

Sigh, okay.  Thanks for the pointer.

--- Additional comment from updates@fedoraproject.org on 2010-02-25 16:41:49 EST ---

anaconda-13.32-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.32-1.fc13

--- Additional comment from updates@fedoraproject.org on 2010-02-27 07:57:49 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-02-28 09:45:44 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-02-28 20:40:17 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-01 19:59:22 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from jlaska@redhat.com on 2010-03-02 10:34:09 EST ---

Removing CommonBugs keyword as this is already fixed in F-13-Alpha-RC4 (anaconda-13.32-1.fc13)

--- Additional comment from updates@fedoraproject.org on 2010-03-02 20:59:17 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-03 03:17:04 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-03 19:22:08 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-03 20:32:39 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

--- Additional comment from updates@fedoraproject.org on 2010-03-04 22:32:15 EST ---

anaconda-13.32-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Radek Vykydal 2010-06-17 07:10:50 EDT
Hit on rhel6 too, we need to port
commit 8ed1789952c33485125cd8a177c97c3c52b8a96c from master.

It might be difficult to reproduce - that is perform upgrade with specific fails - at the moment.

For me it was reproducible by upgrading rehl6-beta1 to rhel6 0610 nightly with hack in updates.img turning upgradeany on in anaconda. There should be rpm error of this kind (taken from /root/upgrade.log) so that the traceback occurs:

warning: %postun(cyrus-sasl-2.1.23-4.1.el6.i686) scriptlet failed, exit status 6
warning: %postun(dmraid-1.0.0.rc16-7.el6.i686) scriptlet failed, exit status 1
Comment 3 RHEL Product and Program Management 2010-06-17 07:18:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Radek Vykydal 2010-06-22 10:51:53 EDT
This should be fixed in anaconda-13.21.53-1.
Notes on reproducing are in comment #2.
Comment 6 Radek Vykydal 2010-07-09 05:44:55 EDT
*** Bug 612802 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Todorov 2010-07-19 08:51:51 EDT
In anaconda-13.21.58 (snap #8) the patch from comment #2 is present. 

An upgrade from Beta1 to snapshot #8 (Server, default install) completed without anaconda traceback. I had a %post scriptlet fail but that didn't cause troubles. Moving to VERIFIED.
Comment 8 releng-rhel@redhat.com 2010-11-10 14:48:25 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.