Bug 605212 - gstreamer-plugins-good-devel-docs has improper provides.
Summary: gstreamer-plugins-good-devel-docs has improper provides.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: koji   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-17 12:42 UTC by Levente Farkas
Modified: 2013-01-10 06:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-18 16:51:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Levente Farkas 2010-06-17 12:42:56 UTC
look into this scratch build:
http://koji.fedoraproject.org/koji/getfile?taskID=2255253&name=root.log
it try to install gstreamer-plugins-good-devel:
---------------------------------
DEBUG backend.py:605:  /usr/bin/yum --installroot /var/lib/mock/dist-f13-build-811120-117788/root/  resolvedep  'ant-junit' 'ant' 'jpackage-utils' 'jna' 'libswt3-gtk2' 'gstreamer-plugins-good-devel' 'junit4' 'java-devel >= 1:1.6.0'
---------------------------------
then why not install it and why install gstreamer-plugins-good-devel-docs?

Comment 1 Jesse Keating 2010-06-17 19:10:53 UTC
This is because the gstreamer-plugins-good-0.10.23-1.fc13 build has issues, in that the -docs subpackage actually provides -devel, which is incorrect.

Re-assigning.

Comment 2 Jesse Keating 2010-06-17 19:21:32 UTC
Erm, reading further, there is no -devel like files for gstreamer-plugins-good, there are just documentation files, hence -docs.  Is your build failing somewhere?

Comment 3 Levente Farkas 2010-06-17 19:31:56 UTC
i find some:-)
releases/12/Everything/i386/os/Packages/gstreamer-plugins-good-devel-0.10.16-7.fc12.i686.rpm
releases/13/Everything/i386/os/Packages/gstreamer-plugins-good-devel-0.10.21-2.fc13.i686.rpm
?

Comment 4 Jesse Keating 2010-06-17 19:40:13 UTC
Right, those are older builds, and in those "-devel" packages there aren't any development files.  I think you may have an incorrect build require on gstreamer-plugins-good-devel, it doesn't actually give you anything useful.  So again, are you having a build failure of some sort?

Comment 5 Levente Farkas 2010-06-17 20:20:19 UTC
i just assume that was the reason why it's not build for dist-f12-updates-candidate. now i see mock install jna-3.0.9 and not jna-3.2.4 since it's among updates.

Comment 6 Levente Farkas 2010-06-17 20:39:46 UTC
ok so my question change why dist-f12-updates-candidate install jna-3.0.9 in stead of jna-3.2.4.

Comment 7 Jesse Keating 2010-06-18 16:51:59 UTC
A lingering buildroot override.  This has been fixed and the latest jna will be available soon.

Comment 8 Levente Farkas 2010-06-18 18:36:07 UTC
and how can i check (other than try a scratch build) what is the jna status? is there any general way, web interface for this?

Comment 9 Jesse Keating 2010-06-18 18:57:57 UTC
Generally you can use 'koji wait-repo' in order to wait for a specific build to show up in a repo.  Enough time has passed so you should be able to attempt your build.


Note You need to log in before you can comment on or make changes to this bug.