Bug 605218 - Documented bonding module option does not exist.
Documented bonding module option does not exist.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Douglas Silas
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 09:07 EDT by Lee Yarwood
Modified: 2016-06-17 17:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 20:15:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2010-06-17 09:07:57 EDT
Description of problem:
Documentation regarding bonding module options for debug output are incorrect for RHEL5.5

Version-Release number of selected component (if applicable):

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.5/html/Deployment_Guide/s2-modules-bonding.html

How reproducible:
Checked that the bonding module does not provide a debug option.
# modinfo bonding | grep debug

 
Actual results:
No debug option present in the bonding module.

Expected results:
Either a debug option in the bonding module _or_ no debug listed in the documentation.

Additional info:
I'm not sure if this a bonding 'bug' (lack of debug) or just old documentation that was not updated...
Comment 1 Douglas Silas 2010-07-13 07:48:28 EDT
grep -i debug $(rpm -ql kernel-doc |grep bonding)

...gives no results. The debug option has evidently removed, so this looks like a documentation fix.

Andy, is the fix to simply remove debug from the list of bonding module options in the Deployment Guide? 

Thanks,

Silas
Comment 2 Andy Gospodarek 2010-07-13 20:15:02 EDT
The documentation needs to stay, as I see the bonding option in the code and on a running system:

[gospo@quad rhel5.5.z]$ grep debug drivers/net/bonding/bond_main.c 
int debug = 0;
module_param(debug, int, 0);
MODULE_PARM_DESC(debug, "Print debug messages; 0 for off (default), 1 for on");

# modinfo bonding | grep debug
parm:           debug:Print debug messages; 0 for off (default), 1 for on (int)
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.5 (Tikanga)
# uname -rp
2.6.18-194.el5 x86_64

please check to see that you are running 5.5 and reopen if needed.

Note You need to log in before you can comment on or make changes to this bug.