Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605251 - RAID not detected, and very ambiguous texts in subsequent screens
RAID not detected, and very ambiguous texts in subsequent screens
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 10:09 EDT by alauschke
Modified: 2012-08-16 17:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 17:52:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (4.80 KB, text/plain)
2010-06-24 14:44 EDT, alauschke
no flags Details
Program log (11.61 KB, text/plain)
2010-06-24 14:45 EDT, alauschke
no flags Details
Storage log (90.34 KB, text/plain)
2010-06-24 14:45 EDT, alauschke
no flags Details
Syslog (49.52 KB, application/octet-stream)
2010-06-24 14:45 EDT, alauschke
no flags Details
Anaconda yum config (345 bytes, application/octet-stream)
2010-06-24 14:46 EDT, alauschke
no flags Details

  None (edit)
Description alauschke 2010-06-17 10:09:29 EDT
Description of problem:
The RAID is not detected. I get two screens that force me to "pick" drives. First I have to pick drives "to use". Then on the second screen I have to pick drives on which I want to install the upgrade. Then I have to pick one for boot in radio buttons. I shouldn't have to do this. Obviously, in a RAID you want to use ALL drives included in the RAID (in my case: two!), and you want the upgrade to be installed on BOTH drives. Which one do I pick? And why do I even get that question? It was working on the F12 upgrade.

Then, a very senior RHAT developer informs me that he thinks that even after the partition config screen (several screens later) it probably wouldn't recognize the RAID again. This is really horrible! Is anaconda tearing my RAID apart?

Next, the whole install process doesn't inform me about what is going on, what is being done, etc. I'd expect something like a "RAID detected ..." message RIGHT AT THE BEGINNING! Professional software design means the user is informed about the state of knowledge the system has about a few KEY ELEMENTS, and the fact that the RAID was recognized is certainly something to TELL the user.

Next, the headings above the panels don't match the terminology used in the text above them. "Install Targets"? This is never referred to in the texts above. "Data drive" ... what is a "data drive"? Is that a drive that contains no o/s, only data files, like an external drive used for backup? One that contains no boot partition? In my understanding a drive that contains an o/s or even a boot partition is not a data drive. But then the screen won't proceed, because I have to select at least one. So a drive that contains an o/s is apparently still a "data drive". OK, but then what's the point of the question? "System drives" ... what's a system drive? And why should it matter? Key is where to put the boot partition. Of course, when someone selects "upgrade" at the beginning, the user wants NO CHANGES to the filesystem layout and partitioning structures, but simply upgrading from F12 to F13 with the EXISTING filesystem. I don't think anaconda should be used to do a) upgrading from F12 to F13 and b) making changes to configs of data drives, system drives, boot partitions, filesystem layouts all at the same time. So then why not assume the user wants to KEEP the current filesystem, and simply upgrade? Why do I even get all these questions?

Next, the text "to install the operating system on" can be understood to mean "to make the boot partition" or "to use as boot partition". Make clear what you mean!

Next, the text "these may be formatted" don't make clear that it's still the user's choice whether or not they will *actually* be formatted (to be determined in later screens). If I read "these may be formatted", it includes the case that anaconda, on its own, decides to format my drives ("hey, we told you that they may be formatted!"). It's clear to YOU, but you don't tell the user unambiguously what is happening. What's really happening would be better described by something like "you later can designate drives to be formatted". 

What does the perplexed user do? Aborts the install process, and seeks clarification on #fedora or in bug reports. Shouldn't be that way! Please understand that professional software design means that you KEEP the user in charge, keep him informed, and eliminate ambiguity. I have now aborted the F13 upgrade three times on a live web server because the texts don't match, you keep me guessing as to what you mean, I don't understand what will happen when I make my choices.

Professional software design also means that regression tests are run. If the RAID was detected perfectly in the F12 upgrade DVD (as it was), why not on the F13 upgrade DVD? A basic lesson from unit-testing says "once it's green, it can never turn red again". Well, here we have a case where something that was working perfectly before does no longer. Not cool at all. Even Microsoft runs regression tests and unit tests.

I'd use preupgrade if that didn't have RAID-related bugs before that caused me and someone else a lot of work to clean up afterwards. Several people recommended me to use the DVD and not preupgrade because it's too risky, but now I find new RAID-related bugs on the DVD version too that didn't exist before. Should I try preupgrade now? Are these RAID bugs in preupgrade fixed?

Version-Release number of selected component (if applicable):
F13

How reproducible:
Just boot into the 64 bit DVD with a RAID server (virtual RAID, not hardware RAID, I didn't test it with a hardware RAID)


Actual results:
RAID not detected, and very ambiguous language in subsequent screens.

Expected results:
Oh, see above. As I said, I expect a) the RAID to be detected and b) better INFORMATION/COMMUNICATION to the user about what is going on.
Comment 1 David Lehman 2010-06-17 18:25:48 EDT
Are you trying to install or upgrade? They're not the same thing, and you seem to be using the terms interchangeably, which is ambiguous.

Do you have the logs from your installation attempt? During installation, they can be found by switching to vt2 (press ctl+alt+f2) and looking in /tmp for anaconda.log, storage.log, program.log, and syslog. Please collect these logs and attach them to this bug report.

As you may have imagined, you are not the first one to try to install (or upgrade) Fedora 13 over a pre-existing software RAID setup. Yes, it generally works -- that's why we need better information from you to see what about your configuration is special. Thanks in advance.
Comment 2 alauschke 2010-06-17 18:43:21 EDT
Are you trying to install or upgrade?

Upgrade from F12 to F13, as I wrote

They're not the same thing

Correct

and you seem
to be using the terms interchangeably, which is ambiguous.

Beg to differ. Tell me an ambiguous sentence in what I wrote. It's ok to refer to anaconda as "the installer", even though the user attempts an upgrade.

Do you have the logs from your installation attempt? 

No. My installation was F8 some time in spring 2008. Everything subsequently was upgrades.
Comment 3 David Lehman 2010-06-17 18:59:59 EDT
If we are able to detect an upgradable installation, we will offer the option to upgrade after the first storage device selection/filtering screen. There is no disk partitioning step in an upgrade.

Beside the point, but the phrase "install the upgrade" (from your fourth sentence) is fairly ambiguous.

Please attach the logs from your *upgrade* attempt.
Comment 4 alauschke 2010-06-24 14:44:39 EDT
Created attachment 426677 [details]
Anaconda log
Comment 5 alauschke 2010-06-24 14:45:06 EDT
Created attachment 426678 [details]
Program log
Comment 6 alauschke 2010-06-24 14:45:29 EDT
Created attachment 426679 [details]
Storage log
Comment 7 alauschke 2010-06-24 14:45:48 EDT
Created attachment 426681 [details]
Syslog
Comment 8 alauschke 2010-06-24 14:46:59 EDT
Created attachment 426682 [details]
Anaconda yum config
Comment 9 alauschke 2010-06-24 14:54:51 EDT
Sorry it took me so long, I needed to figure out which device to mount when it was running in the RAM drive, and then when I rebooted into my working F12 installation, the files I had copied to the sda1 mount was in a different location, in /boot.

the phrase "install the upgrade" (from your fourth
sentence) is fairly ambiguous

beg to differ. An upgrade needs to be installed. According to the dictionary "to install" means "to set in position and prepare for use". And that's what needs to be done with a software upgrade: put in position and prepared for use.

Files uploaded. I also saved storage.state, in case that would provide useful clues to someone.

Another observation that might be helpful: on the screen where I have to choose between an install and an upgrade, I cannot really click the version that is already installed and is supposed to be upgraded. It says something with md0. But when I click on it, this turns blue, but then doesn't stay selected. Whenever I release the mouse, it becomes deselected. It's the only way to proceed to the next screen. Is it possible the bug is simply that the radio button at the left is ignored, and it's only made dependent on whether or not a current install is selected, but that selection doesn't stay? Just a guess, because I notice that my selection doesn't stay. I would expect it to KEEP my selection in blue, once I have clicked on it. But even then the radio button choice at the left should prevail.
Comment 10 alauschke 2010-07-14 20:55:28 EDT
I didn't hear back from anyone on this. I guess it's "on hold"?

Does preupgrade suffer from the same problem? There is no need for me to use the DVD. If preupgrade doesn't suffer from this same problem, I can easily do preupgrade, then I don't have to wait. I'd rather upgrade to F13 sooner than later, and preupgrade is even easier than the DVD upgrade (when it works).
Comment 11 alauschke 2010-08-05 08:18:20 EDT
Another request to let me know if preupgrade suffers from the same problem. There is no need for me to use the DVD. I only used the DVD version because preupgrade had RAID problems before. If preupgrade is fixed, I could use preupgrade, and this bug won't affect me.
Comment 12 alauschke 2011-01-19 15:42:08 EST
Still not fixed for the F13->F14 upgrade. Reopening.

It should NEVER happen that selecting "upgrade" instead of "install" proceeds in install mode, forcing the user to pick volumes for "installation".

Everything is still as described above, which was for the F12->F13 DVD.
Comment 13 Chris Lumens 2011-01-19 15:52:48 EST
Oh, then what you're seeing was fixed in bug 649865.

*** This bug has been marked as a duplicate of bug 649865 ***
Comment 14 Harald Hoyer 2011-01-19 16:30:48 EST
This is not a duplicate, because the RAID, on which the old root resides is not assembled, and thus no "update" could be performed.
Comment 15 David Lehman 2011-01-19 19:50:27 EST
(In reply to comment #12)
> Still not fixed for the F13->F14 upgrade. Reopening.

Please attach all the same logs from the F14 failed upgrade attempt. Thanks.
Comment 16 alauschke 2011-01-19 20:36:52 EST
Well, this will have to wait a while now. This is a webserver with a lot of load and uptime requirements (hence the RAID), I cannot just take it down to reboot from DVD. This is a bit of a project for me to reboot this webserver into a DVD. You have to wait now.
Comment 17 David Lehman 2011-01-19 20:45:12 EST
Not a problem. Send them when you can. I am setting the NEEDINFO flag to reflect the bug's state until you provide the logs.
Comment 18 David Lehman 2011-10-17 15:48:31 EDT
If you're going to provide the logs please do so before the end of this month. Otherwise I will close this bug as a result of insufficient info.
Comment 19 Dennis Flaherty 2012-06-10 11:18:50 EDT
Trying to upgrade from F16 to F17.  My /, /boot, and swap are all md RAID-1 (parallel partitioning of two HDD's).  Using the DVD, Anaconda doesn't recognize the RAID partitions and instead offers to wipe everything out for a clean install.

I just want to upgrade.  What should I do?
Comment 20 David Lehman 2012-06-11 09:37:04 EDT
(In reply to comment #19)
> Trying to upgrade from F16 to F17.  My /, /boot, and swap are all md RAID-1
> (parallel partitioning of two HDD's).  Using the DVD, Anaconda doesn't
> recognize the RAID partitions and instead offers to wipe everything out for
> a clean install.
> 
> I just want to upgrade.  What should I do?

You should provide your logs so I can see what is happening.

/tmp/anaconda.log
/tmp/storage.log
/tmp/syslog
/tmp/program.log

Do not create an archive and attach that. Instead, attach the files one at a time as type text/plain.
Comment 21 Fedora End Of Life 2012-08-16 17:52:10 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.