Bug 605310 - Distros > Family sorting broken
Distros > Family sorting broken
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
UX
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 11:54 EDT by Marian Csontos
Modified: 2016-05-09 20:01 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-09 20:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2010-06-17 11:54:14 EDT
Description of problem:
Whatever sort order I select distros are sorted by unknown strange criteria. (id?)

Version-Release number of selected component (if applicable):
0.5.43

How reproducible:
100%

Steps to Reproduce:
1. select Distros > Family
2. try to sort the list
  
Actual results:
List is unsorted in some way.

Expected results:
Sorted list

Additional info:
Comment 1 Raymond Mancy 2010-06-17 19:21:28 EDT
This is also a problem in Admin->OSVersions (which is the page this one copies). I'll look into it
Comment 2 Raymond Mancy 2012-04-23 12:40:45 EDT
This is still an issue. Fedora10 is displayed before Fedora8. Need to use a similar comparator as in the distro list in the reserve workflow.
Comment 3 wangjing 2013-06-19 23:08:25 EDT
reopen it because issue in comment2 still exists.
Comment 5 Dan Callaghan 2016-05-09 20:01:41 EDT
This is not actually easy to fix since currently the sorting and pagination is done on the MySQL side and there is no collation we can use to make it sort Fedora8 before Fedora10.

This also doesn't seem to be too serious an issue (the current ordering is not *completely* wrong/broken) and we are hoping to get rid of all this distro library UI in the medium term once we switch Beaker to get its distro metadata from PDC. Therefore WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.