Bug 60533 - SDL detection in AM_PATH_SDL automake macro is incorrect
SDL detection in AM_PATH_SDL automake macro is incorrect
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: SDL (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 01:44 EST by vvs
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-01 01:55:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configure script (136 bytes, text/plain)
2002-03-01 01:54 EST, vvs
no flags Details

  None (edit)
Description vvs 2002-03-01 01:44:05 EST
Description of Problem:

AM_PATH_SDL macro can't detect SDL presence when C++ compiler is used. This
happens because it sets up CFLAGS only, but not CXXFLAGS.

Version-Release number of selected component (if applicable):

SDL-1.2.3-5

How Reproducible:

Always

Steps to Reproduce:
1. Save attached configure.ac
2. touch Makefile.am
3. aclocal
4. automake -a -c
5. autoconf
6. ./configure

Actual Results:

SDL was not detected.

Expected Results:

It should say SDL version >= 1.2.0 yes

Additional Information:
	
If you remove AC_LANG from configure.ac all will be ok.
Comment 1 vvs 2002-03-01 01:54:56 EST
Created attachment 47060 [details]
configure script
Comment 2 Bernhard Rosenkraenzer 2002-03-11 09:19:48 EST
Fixed in 1.2.3-7

Note You need to log in before you can comment on or make changes to this bug.