Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605335 - Bad permissions on tomcat folders
Bad permissions on tomcat folders
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tomcat6 (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 627895
  Show dependency treegraph
 
Reported: 2010-06-17 12:33 EDT by Henrik Nordström
Modified: 2015-11-01 19:15 EST (History)
11 users (show)

See Also:
Fixed In Version: tomcat6-6.0.26-11.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 643809 (view as bug list)
Environment:
Last Closed: 2010-11-01 16:54:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Nordström 2010-06-17 12:33:55 EDT
Description of problem:

A number of standard tomcat folders is missing tomcat group write permission

Version-Release number of selected component (if applicable):

tomcat6-6.0.20-2.fc13.noarch

How reproducible:

always

Steps to Reproduce:
1. yum install tomcat6
2. service tomcat6 start
3.
  
Actual results:

Log files missing, applications fail with "No output folder" and other errors.'

group write permission missing on
/var/lib/tomcat6/webapps/
/var/log/tomcat6/
/var/cache/tomcat6/temp
/var/cache/tomcat6/work

Expected results:

Permissions set up allowing tomcat to work.

Additional info:
Comment 1 Milan Zázrivec 2010-08-04 08:24:16 EDT
This bug is a blocker for a successful Spacewalk 1.1 @ Fedora-13
installation.

Updated tomcat6 for Fedora-13 would be very much appreciated.
Comment 2 Johan Cwiklinski 2010-09-09 10:41:46 EDT
Issue is still present, it is not possible to get tomcat running "out-of-the-package", had to change rights myself.

PS: this bug was assigned to 'orphan', I've ressigned it to the default for th component
Comment 3 Partha Aji 2010-09-09 13:36:04 EDT
*** Bug 627895 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-10-12 14:20:08 EDT
tomcat6-6.0.26-3.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/tomcat6-6.0.26-3.fc12
Comment 6 Fedora Update System 2010-10-12 16:58:42 EDT
tomcat6-6.0.26-11.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/tomcat6-6.0.26-11.fc13
Comment 7 Fedora Update System 2010-10-14 02:25:56 EDT
tomcat6-6.0.26-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tomcat6'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/tomcat6-6.0.26-3.fc12
Comment 9 Fedora Update System 2010-11-01 16:53:58 EDT
tomcat6-6.0.26-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2010-11-01 16:56:26 EDT
tomcat6-6.0.26-11.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Phil 2011-05-01 04:15:41 EDT
This problem exists again in F15 Development.

I discovered this issue just yesterday while trying to install and learn spacewalk

Pkg Ver.:
tomcat6-6.0.30-6.fc15

Details:
Minimal install
yum install spacewalk-postgresql etc.
I followed the bouncing ball in the install instructions, https://fedorahosted.org/spacewalk/wiki/HowToInstall , and everything was clockwork.

Note You need to log in before you can comment on or make changes to this bug.