Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 605347 - [abrt] crash in tortoisehg-1.0.4-1.fc13: _IO_default_xsputn: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] crash in tortoisehg-1.0.4-1.fc13: _IO_default_xsputn: Process /usr/bin...
Status: CLOSED DUPLICATE of bug 578931
Product: Fedora
Classification: Fedora
Component: tortoisehg (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Mads Kiilerich
Fedora Extras Quality Assurance
abrt_hash:288690f1de253d8d78dead9e4c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 13:08 EDT by Neal Becker
Modified: 2010-06-17 16:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 16:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (185.76 KB, text/plain)
2010-06-17 13:08 EDT, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2010-06-17 13:08:39 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/hgtk merge
component: tortoisehg
crash_function: _IO_default_xsputn
executable: /usr/bin/python
global_uuid: 288690f1de253d8d78dead9e4c4f55ac32a9ca54
kernel: 2.6.33.5-124.fc13.x86_64
package: tortoisehg-1.0.4-1.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. hgtk merge (with no args or options)
2.
3.
Comment 1 Neal Becker 2010-06-17 13:08:41 EDT
Created attachment 424884 [details]
File: backtrace
Comment 2 Mads Kiilerich 2010-06-17 16:47:43 EDT
That looks like a segmentation fault while trying to handle an assertion in pygobject.

More specific instructions for reproducing (on x86):

In hg repo with single head run "hgtk merge".
"Unable to merge" messagebox, choose Close.
See "Merging in hg" window with 4 grey buttons, but after few seconds it dumps core.
Comment 3 Mads Kiilerich 2010-06-17 16:54:15 EDT

*** This bug has been marked as a duplicate of bug 578931 ***

Note You need to log in before you can comment on or make changes to this bug.