Bug 605380 - anaconda crash python - again
anaconda crash python - again
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:fc4a9248cab484e63...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 15:21 EDT by sem
Modified: 2010-06-18 11:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
FC11 32bit, create 1GB VMWARE disk, attempt to install Linux, it will crash.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-17 19:24:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (100.14 KB, text/plain)
2010-06-17 15:21 EDT, sem
no flags Details

  None (edit)
Description sem 2010-06-17 15:21:11 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devices.py", line 2048, in _setSize
    raise ValueError("not enough free space in volume group")
  File "/usr/lib/anaconda/storage/partitioning.py", line 1163, in growLVM
    lv.size += grow_amounts[lv.name]
  File "/usr/lib/anaconda/storage/partitioning.py", line 197, in doAutoPartition
    growLVM(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 712, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 965, in <module>
    anaconda.intf.run(anaconda)
ValueError: not enough free space in volume group
Comment 1 sem 2010-06-17 15:21:20 EDT
Created attachment 424915 [details]
Attached traceback automatically from anaconda.
Comment 2 sem 2010-06-17 15:23:44 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
FC11 32bit, create 1GB VMWARE disk, attempt to install Linux, it will crash.
Comment 3 Chris Lumens 2010-06-17 15:29:10 EDT
Please test with F13 and let us know if this issue still exists.  At this point, F11 is really quite old and an extensive number of storage bug fixes have gone in.
Comment 4 David Lehman 2010-06-17 18:33:32 EDT
You will still not be able to use automatic partitioning with 1GB of disk in F13, although the error message should be a bit clearer. The minimum disk space required for automatic partitioning is somewhere around 2GB. You can either allocate a larger virtual disk or you can partition the disk using the "custom layout" option.
Comment 5 sem 2010-06-17 18:41:12 EDT
thx, custom partitioning fixed it. i created a 1GB and didn't use the rest.

Note You need to log in before you can comment on or make changes to this bug.