Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605386 - [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.
Status: CLOSED DUPLICATE of bug 596330
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 15:42 EDT by David Mansfield
Modified: 2018-04-11 02:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-20 19:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log at time of hang (281.12 KB, text/plain)
2010-06-17 15:42 EDT, David Mansfield
no flags Details
dmesg.out at time of hang (38.27 KB, text/plain)
2010-06-17 15:43 EDT, David Mansfield
no flags Details

  None (edit)
Description David Mansfield 2010-06-17 15:42:38 EDT
Created attachment 424919 [details]
Xorg.0.log at time of hang

Description of problem:
x server hangs.  mouse cursor moves, numlock lights, nothing else works.  system is still reachable via ssh

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.fc13.x86_64

How reproducible:
not very.  happened once a day so far in each day computer has been in service (i.e. twice in two days)

Steps to Reproduce:
1. nothing special being done. just click firefox or evolution
2.
3.
  
Actual results:
see above

Expected results:
not hung


Additional info:
xorg.0.log and dmesg will be attached, here is the relevant stack trace from xorg.0.log for the impatient:

[ 92038.893] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 92038.893] 
Backtrace:
[ 92038.910] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49e708]
[ 92038.910] 1: /usr/bin/Xorg (mieqEnqueue+0x1f4) [0x49e0b4]
[ 92038.910] 2: /usr/bin/Xorg (xf86PostMotionEventP+0xc4) [0x477e24]
[ 92038.910] 3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f0c5024c000+0x3dbf) [0x7f0c5024fdbf]
[ 92038.910] 4: /usr/bin/Xorg (0x400000+0x6aae7) [0x46aae7]
[ 92038.910] 5: /usr/bin/Xorg (0x400000+0x117b43) [0x517b43]
[ 92038.910] 6: /lib64/libc.so.6 (0x3ae5a00000+0x32a20) [0x3ae5a32a20]
[ 92038.910] 7: /lib64/libc.so.6 (ioctl+0x7) [0x3ae5ad9597]
[ 92038.910] 8: /usr/lib64/libdrm.so.2 (drmIoctl+0x28) [0x3afea03388]
[ 92038.910] 9: /usr/lib64/libdrm.so.2 (drmCommandWrite+0x1b) [0x3afea0360b]
[ 92038.910] 10: /usr/lib64/libdrm_nouveau.so.1 (0x7f0c51519000+0x2dfd) [0x7f0c5151bdfd]
[ 92038.910] 11: /usr/lib64/libdrm_nouveau.so.1 (nouveau_bo_map_range+0xfe) [0x7f0c5151bfee]
[ 92038.910] 12: /usr/lib64/libdrm_nouveau.so.1 (0x7f0c51519000+0x207a) [0x7f0c5151b07a]
[ 92038.910] 13: /usr/lib64/libdrm_nouveau.so.1 (nouveau_pushbuf_flush+0x190) [0x7f0c5151b450]
[ 92038.910] 14: /usr/lib64/xorg/modules/libexa.so (0x7f0c5067d000+0x90f1) [0x7f0c506860f1]
[ 92038.910] 15: /usr/lib64/xorg/modules/libexa.so (0x7f0c5067d000+0xeac8) [0x7f0c5068bac8]
[ 92038.910] 16: /usr/bin/Xorg (0x400000+0xd21e0) [0x4d21e0]
[ 92038.910] 17: /usr/bin/Xorg (0x400000+0xcb91e) [0x4cb91e]
[ 92038.910] 18: /usr/bin/Xorg (0x400000+0x2c32c) [0x42c32c]
[ 92038.910] 19: /usr/bin/Xorg (0x400000+0x219ca) [0x4219ca]
[ 92038.910] 20: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x3ae5a1ec5d]
[ 92038.910] 21: /usr/bin/Xorg (0x400000+0x21579) [0x421579]
Comment 1 David Mansfield 2010-06-17 15:43:04 EDT
Created attachment 424921 [details]
dmesg.out at time of hang
Comment 2 Matěj Cepl 2010-06-20 19:03:59 EDT

*** This bug has been marked as a duplicate of bug 596330 ***

Note You need to log in before you can comment on or make changes to this bug.