Bug 60542 - failure on php to connect to mysql after updating php.
failure on php to connect to mysql after updating php.
Status: CLOSED DUPLICATE of bug 60515
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 10:45 EST by Drew Bertola
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-04 01:25:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
one line patch to change default mysql.sock location in configure script (384 bytes, patch)
2002-03-04 01:24 EST, Alastair Tse
no flags Details | Diff

  None (edit)
Description Drew Bertola 2002-03-01 10:45:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020205

Description of problem:
Error shown in web page is something like "php cannot connect to mysql through
/tmp/mysql.sock



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. make sure /etc/php.ini has no value for mysql.default_socket
2. latest php, mysql, apache (php-4.0.6-12.i386.rpm)
3. run a mysql_connect
	

Actual Results:  error message like: "php cannot connect to mysql through
/tmp/mysql.sock"

Expected Results:  Connection success.  The applied rpms for the php security
fix caused this.

Additional info:

This doesn't cause a crash, but it does take down the web server fuctionality of
php+mysql enabled sites when apache gets a HUP (after logrotate).  I suppose I
would have found the problem earlier if I restarted apache manually after the
upgrade, but I didn't want to do that.  My production site was down for 6 hours.
Comment 1 Need Real Name 2002-03-01 12:59:03 EST
Untill they get this fixed you can create a symlink from
/var/lib/mysql/mysql.sock to /tmp/mysql.sock. that got me back up and running.

Is there a config file to fix this or is it compiled into a binary?
Comment 2 Alastair Tse 2002-03-04 01:24:16 EST
Created attachment 47282 [details]
one line patch to change default mysql.sock location in configure script
Comment 3 Alastair Tse 2002-03-04 01:25:24 EST
of course - that means you have to apply that patch before rebuilding that RPM
:) But the softlink from /tmp/mysql.sock works just as well.
Comment 4 Phil Copeland 2002-03-04 14:17:42 EST

*** This bug has been marked as a duplicate of 60515 ***

Note You need to log in before you can comment on or make changes to this bug.