Bug 605420 - Google Earth crashes in libGL.so on startup
Google Earth crashes in libGL.so on startup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mesa-libGLw (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-17 17:22 EDT by Jonathan Ryshpan
Modified: 2018-04-11 05:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 13:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash log generated by Google Earth (3.47 KB, text/plain)
2010-06-17 17:22 EDT, Jonathan Ryshpan
no flags Details

  None (edit)
Description Jonathan Ryshpan 2010-06-17 17:22:53 EDT
Created attachment 424957 [details]
Crash log generated by Google Earth

Description of problem:
As stated

Version-Release number of selected component (if applicable):
google-earth version 5.1.3535.3218-1
mesa-libGL-7.8.1-6.fc13.i686
kmod-nvidia-2.6.33.5-124.fc13.x86_64-195.36.24-1.fc13.5.x86_64

How reproducible:
Completely


Steps to Reproduce:
1. $ googlearth
2.
3.
  
Actual results:
======================== Results Start ========================
Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/jonrysh/.googleearth/crashlogs/crashlog-4c1a8e5f.txt
======================== Results End ========================

Expected results:
googleearth runs

Additional info:
NOTE: This is an x86_64 system running a 32-bit program

The crash happens only with the proprietary nvidia driver, installed via kmod or akmod.  The nouveau driver allows google earth to run without crashing, but too slowly to be useful.  The crash did not happen in Fedora-11 with the proprietary driver.  Crash backtraces (one of which is attached) always show that Google Earth crashes at the same location in the function glXMakeCurrent of libGL.so .  

An odd thing about this driver is that starting the screen saver (under gnome), which faded the screen to black in about 1 second in Fedora-11 with the proprietary driver and in Fedora-13 with the nouveau driver now (in Fedora-13 with the proprietary driver) pauses for about 1 second and then suddenly turns the screen black.
Comment 1 Matěj Cepl 2010-06-21 13:29:56 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customizations that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo
Comment 2 Matěj Cepl 2010-06-21 13:31:50 EDT
Just to add to the previous comment: nvidia binary-only driver replaces free GL subsystem with its own. If googlearth crashes because of this (neither of these apps is provided by Fedora nor there is a source available), we really cannot do anything about it.

Note You need to log in before you can comment on or make changes to this bug.