Bug 605499 - [abrt] crash in opencv-2.0.0-7.fc13: Process /usr/bin/opencv_haartraining was killed by signal 11 (SIGSEGV)
[abrt] crash in opencv-2.0.0-7.fc13: Process /usr/bin/opencv_haartraining was...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: opencv (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Rakesh Pandit
Fedora Extras Quality Assurance
abrt_hash:10cb75282df1e4227b84ac8fb34...
:
: 572451 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 02:17 EDT by Trever Adams
Modified: 2011-06-10 18:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-10 17:03:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (66.79 KB, text/plain)
2010-06-18 02:17 EDT, Trever Adams
no flags Details

  None (edit)
Description Trever Adams 2010-06-18 02:17:36 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: opencv_haartraining -data trainout -vec Human.Buttocks.Nude.vec -bg Human.Buttocks.Nude.neg -nstages 22 -nsplits 5 -maxtreesplits 12 -minhitrate 0.98 -maxfalsealarm 0.5 -npos 769 -nneg 6594 -w 26 -h 26 -mem 1024 -mode ALL -minpos 32.0417 -nonsym
component: opencv
executable: /usr/bin/opencv_haartraining
global_uuid: 10cb75282df1e4227b84ac8fb344fd8a4a5e2e01
kernel: 2.6.33.5-124.fc13.x86_64
package: opencv-2.0.0-7.fc13
rating: 4
reason: Process /usr/bin/opencv_haartraining was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
It appears that this may be the same bug I reported before. It was "fixed" by setting the library to be single threaded (no OpenMP). I have been using that version (provided as a test) and changed to the mainline Fedora one today. The crash is there and OpenMP is back on.

I cannot say whether or not this has anything to do with my other bug reports for opencv package.

How to reproduce
-----
1. Start the trainer
2. Wait
3. Crash
Comment 1 Trever Adams 2010-06-18 02:17:39 EDT
Created attachment 425014 [details]
File: backtrace
Comment 2 Trever Adams 2010-06-21 19:19:48 EDT
One of my five trainers is running, the other three aren't. It seems the ones
that aren't have splits off the 0 node. The one that is didn't do a split until
later in the cascade.

Working: 0-1-2-3
Not working:

0-1
|
2-3

Thank you again.
Comment 3 Nicolas Chauvet (kwizart) 2011-01-07 05:05:58 EST
Hi, and sorry for the late reply.

Can you test with newer release (either OpenCV 2.1 from fc14 or OpenCV 2.2 from fc15 ?).
Can you attach/reference the files used to test opencv_haartraining.
Comment 4 Nicolas Chauvet (kwizart) 2011-01-07 05:07:17 EST
*** Bug 572451 has been marked as a duplicate of this bug. ***
Comment 5 Trever Adams 2011-03-02 03:44:50 EST
I am afraid that at the moment I am unable to duplicate this in F15 (I will keep trying). Also, the data is about 2 gigabytes of data. Not something you want in bugzilla.
Comment 6 Nicolas Chauvet (kwizart) 2011-06-10 17:03:40 EDT
Note that there is still an opencv update that request feedbacks in testing.
(backporting important bugfix)
https://admin.fedoraproject.org/updates/opencv-2.2.0-6.fc15

I'm closing this bug, please reopen if the proble appears for f15.

Thx for the report.
Comment 7 Trever Adams 2011-06-10 18:19:30 EDT
Thank you for fixing all of this.

Note You need to log in before you can comment on or make changes to this bug.