Bug 605508 - XP installed under RHEL55 BSODs when booted under RHEL6
XP installed under RHEL55 BSODs when booted under RHEL6
Status: CLOSED DUPLICATE of bug 607555
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.0
x86_64 Windows
low Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 02:56 EDT by Jes Sorensen
Modified: 2010-06-29 11:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 11:20:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screendump of BSOD (10.24 KB, image/png)
2010-06-18 02:56 EDT, Jes Sorensen
no flags Details
new BSOD of fresh install (11.70 KB, image/png)
2010-06-21 09:33 EDT, Jes Sorensen
no flags Details
dump from bsod v2 (12.34 KB, application/x-gzip)
2010-06-21 09:37 EDT, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2010-06-18 02:56:48 EDT
Created attachment 425020 [details]
Screendump of BSOD

Description of problem:
Installing XP under RHEL55, activating it, rebooting the host into RHEL6 and trying to boot the XP guest results in a BSOD. It comes up, tries to install the genuine validation tool or something, then explodes in the BSOD.


Version-Release number of selected component (if applicable):
1.1.5

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Installed under RHEL55 like this:
/usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=/var/lib/libvirt/images/xp3.img,if=virtio,cache=off,boot=on -net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:20:10 -net tap,vlan=1,script=/etc/kvm-ifup.sh -boot dc -uuid 17544ecc-d3a1-4d3c-a386-12daf50015f1 -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -name xp-test -fda /home/jes/virtio-win-1.1.5-0.vfd -cdrom /home/isos/en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -vnc 127.0.0.1:0

Rebooted under RHEL6 like this:
/usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=/var/lib/libvirt/images/xp3.img,if=virtio,cache=off,boot=on -net nic,model=virtio,vlan=1,macaddr=02:00:40:3F:20:10 -net tap,vlan=1,script=/etc/kvm-ifup.sh -boot c -uuid 17544ecc-d3a1-4d3c-a386-12daf50015f1 -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio  -balloon none -startdate now -name xp-test  -cdrom /home/isos/en_windows_xp_professional_with_service_pack_3_x86_cd_x14-80428.iso -vnc 127.0.0.1:0
QEMU 0.12.1 monitor - type 'help' for more information
(qemu) virtio_ioport_write: unexpected address 0x13 value 0x1

Note the strange virtio_ioport_write message.
Comment 2 RHEL Product and Program Management 2010-06-18 03:14:56 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Yan Vugenfirer 2010-06-19 05:14:51 EDT
If possible please extract memory dump from the guest (boot it again in RHEL5.5).

Memory dumps should be in c:\windows\memory.dmp or c:\windows\minidumps
(better configure OS to generate kernel memory dumps before the crash).
Comment 4 Jes Sorensen 2010-06-21 08:04:21 EDT
I will try to see if I can extract the info.

I just tried rebooting under RHEL55 but no it claims that autochk doesn't exist, then reboots and tries again, then fails again ....

I will try and reinstall it and see if I can reproduce it and pull it out.

Jes
Comment 5 Jes Sorensen 2010-06-21 09:33:26 EDT
Created attachment 425628 [details]
new BSOD of fresh install
Comment 6 Jes Sorensen 2010-06-21 09:37:21 EDT
Created attachment 425631 [details]
dump from bsod v2

Here is the minidump which matches the BSOD I attached in attachment #425628 [details]

Jes
Comment 7 Jes Sorensen 2010-06-29 11:20:07 EDT

*** This bug has been marked as a duplicate of bug 607555 ***

Note You need to log in before you can comment on or make changes to this bug.