Bug 605521 - Provide manual page for urlgrabber
Summary: Provide manual page for urlgrabber
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Peter Schiffer
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch, Reopened
Depends On:
Blocks: 799934
TreeView+ depends on / blocked
 
Reported: 2010-06-18 07:36 UTC by Petr Šplíchal
Modified: 2016-06-01 01:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 14:49:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Manpage for urlgrabber utility (4.83 KB, text/plain)
2011-06-17 11:31 UTC, Phil Knirsch
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0961 normal SHIPPED_LIVE man-pages-overrides bug fix update 2012-06-19 20:59:32 UTC

Description Petr Šplíchal 2010-06-18 07:36:47 UTC
Description of problem:

There should be a man page for the command line tool "urlgrabber"
which is part of python-urlgrabber package.

Version-Release number of selected component (if applicable):
python-urlgrabber-3.9.1-6.el6.noarch

Comment 1 RHEL Product and Program Management 2011-01-07 15:54:52 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 2 Phil Knirsch 2011-06-09 14:02:25 UTC
Currently there is only a pydoc for urlgrabber available via:

pydoc urlgrabber

which is very similar to what we do for other languages like perl and additional modules for them.

That should be sufficient as a documentation and a standard for python modules.

Thanks & regards, Phil

Comment 3 Petr Šplíchal 2011-06-13 15:04:20 UTC
(In reply to comment #2)

> which is very similar to what we do for other languages like
> perl and additional modules for them.
> 
> That should be sufficient as a documentation and a standard for
> python modules.

I understand, as far as python module is concerned. But does
that apply for the /usr/bin/urlgrabber binary as well? I guess
command line utilities should have their man pages available.

Comment 5 Phil Knirsch 2011-06-17 11:30:04 UTC
Hm, true Petr. The urlgrabber upstream repo doesn't have a manpage, but there exists one for Debian and Ubuntu which is distributed under GPL V2+, so we should be able to use that.

But as it's not critical and we're past the planing phase for 6.2 i'm moving this to 6.3 Fast.

Thanks & regards, Phil

PS: Attached said manpage for inclusion.

Comment 6 Phil Knirsch 2011-06-17 11:31:01 UTC
Created attachment 505250 [details]
Manpage for urlgrabber utility

Comment 14 errata-xmlrpc 2012-06-20 14:49:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0961.html


Note You need to log in before you can comment on or make changes to this bug.