Bug 605527 - KNetworkManager can´t connect to DSL/PPPoE connection
KNetworkManager can´t connect to DSL/PPPoE connection
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
14
All Linux
high Severity urgent
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 03:50 EDT by Angel
Modified: 2015-07-13 13:37 EDT (History)
12 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 18:59:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 228464 None None None Never
KDE Software Compilation 242088 None None None Never

  None (edit)
Description Angel 2010-06-18 03:50:19 EDT
Description of problem:
In Fedora 13, under KDE, after adding new dsl connection in KNetworkManager, when I click KNetworkManager applet from the panel, it does not show any dsl connection. Just one connection ¨System eth0¨. And so it can´t connect. And no connection.

Here is the screenshots, how I tried connecting:

http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2001.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2002.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2003.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2004.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2005.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2006.jpg
http://angel.fedorapeople.org/angel/KNetworkManager%20Bug/KNetworkManager%2007.jpg

Version-Release number of selected component (if applicable): Currently my full system is up to date. Currently I am running KDE 4.4.4-1 and knetworkmanager-1:0.9.0.19.20100419.

How reproducible:
Set up a new DSL Connection using KNetworkManager, use any random username and password if you don´t use DSL, and you will see, it doesn´t show any DSL connection when you will click the KNetworkManager applet. Even if you don´t use DSL, but when you will create the connection, it should appear in the connection list, right? 

Steps to Reproduce:
1. Right or Left click on the KNetworkManager applet > Manage Connections > DSL > ADD > Type Username and Password, check Connect automatically > Ok > Ok.
2. Now right or left click on the KNetworkManager, there has no DSL connection except the default System eth0.

  
Actual results:
No DSL connection to connect. And can´t connect to internet as well.

Expected results:
As I have entered all of the information, including the username and password of my network, it
should show the connection in the connection list, and by clicking the DSL connection it should connect. just like it does when I use nm applet in Gnome.

Additional info:
I don´t have any problem to connect the DSL connection using nm applet in Gnome, Fedora 13.

I tried Fedora 13 Beta, same problem occurred. And in Fedora 11 and 12, even nm was default network manager for KDE, but still I tried testing KNetworkManager, and same problem I faced. I visited Fedora Forum and also #fedora channel in Freenode, could not help anyone. I can use nm applet in KDE, but this is not a permanent solution.
Comment 1 dspikaman 2010-10-17 13:58:09 EDT
@Angel What mainframe are you running?(In reply to comment #0)
Comment 2 Alex G. 2010-10-17 16:35:39 EDT
I have the *exact* same issue.
Comment 3 Alex G. 2010-10-19 06:02:09 EDT
I can reproduce the problem with Ubuntu 10.10.
There's also a problem with connecting using GSM/CDMA usb gadgets. nm-applet works as expected.

It's beginning to look a lot like Christmas!!! (Umh, I mean upstream issue)

I propose this as a high priority bug. Hopefully, it can be solved by the time F14 comes out, or at least as an update not long after.
Comment 4 dspikaman 2010-10-29 18:52:59 EDT
Changed to Urgent Severity, High priority.
Comment 5 dspikaman 2010-10-30 15:16:41 EDT
This is probably inside KDE instead of Fedora or Ubuntu kernels.
Comment 6 Alex G. 2010-11-02 16:48:05 EDT
Problem persits with kde-plasma-networkmanagement-0.9-0.28.20101011.fc14.x86_64
Comment 7 Angel 2010-11-09 11:05:29 EST
Yeah, Fedora 14 KDE also has same bug! And so is Ubuntu 10.10 KDE!
Comment 8 Lukáš Tinkl 2011-09-07 10:40:31 EDT
Does it still happen in F15?
Comment 9 Fedora Update System 2011-09-09 19:16:20 EDT
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-11509
Comment 10 Fedora Update System 2011-09-15 13:47:23 EDT
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15
Comment 11 Fedora Update System 2011-09-15 22:00:37 EDT
Package kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15
then log in and leave karma (feedback).
Comment 12 Kevin Kofler 2011-09-18 04:46:02 EDT
Looks like the Sep 7 snapshot is too old, we need at least:
https://projects.kde.org/projects/extragear/base/networkmanagement/repository/revisions/2a26ff257ca588ce96d5f443795c82d96140f7e0
from Sep 10 to fix this.
Comment 13 Fedora Update System 2011-09-18 05:52:43 EDT
kde-plasma-networkmanagement-0.9-0.41.3.20110918git.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.41.3.20110918git.fc14
Comment 15 Fedora Update System 2011-09-18 18:59:28 EDT
Package kde-plasma-networkmanagement-0.9-0.58.20110918git.nm09.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9-0.58.20110918git.nm09.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.58.20110918git.nm09.fc15
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2011-09-27 18:58:42 EDT
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2011-09-27 19:04:15 EDT
kde-plasma-networkmanagement-0.9-0.41.3.20110918git.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2011-09-30 14:50:51 EDT
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Angel 2011-10-01 08:21:17 EDT
Thanks a lot. Tested on Fedora 15 and rawhide. The last update fixed this issue.

Note You need to log in before you can comment on or make changes to this bug.