Bug 605533 - No IPv6 support in python-ethtool
No IPv6 support in python-ethtool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-ethtool (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Neil Horman
Petr Šplíchal
: FutureFeature
Depends On: 680269
Blocks: 519903
  Show dependency treegraph
 
Reported: 2010-06-18 04:02 EDT by Petr Šplíchal
Modified: 2016-05-31 21:39 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:25:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2010-06-18 04:02:37 EDT
Description of problem:

Currently there is no support for handling IPv6 in ethtool.
There's already a suggested patch providing this functionality.
See bug 569793 for more details.

Version-Release number of selected component (if applicable):
python-ethtool-0.3-5.1.el6.x86_64
Comment 1 RHEL Product and Program Management 2010-06-18 04:13:14 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Jeff Garzik 2010-07-14 19:14:20 EDT
Does the patch in bug 569793 work?  Do we have any testers?
Comment 4 Petr Šplíchal 2010-07-15 05:33:07 EDT
I've checked basic functionality of the patch with the RHEL6
python-ethtool package & everything seems to be ok:

    ** Device: lo
    MAC addr: 00:00:00:00:00:00
    IPv4: 127.0.0.1/8   Brd: None
    IPv6: ::1/128

    ** Device: eth0
    MAC addr: 00:17:a4:3b:4f:34
    IPv4: 10.16.113.0/22   Brd: 10.16.115.255
    IPv6: fec0:0:a10:7000:217:a4ff:fe3b:4f34/64

    ** Device: eth1
    MAC addr: 00:17:a4:3b:4f:33
    IPv4: None/0   Brd: None
    IPv6: None/0

CCing David, as he mentioned (in bug 569793) he was still working
on the implementation and that it was not completely done at that
time.
Comment 5 RHEL Product and Program Management 2010-07-15 10:46:52 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 9 Miroslav Suchý 2010-08-03 11:24:37 EDT
RHN Satellite team would like to have it in RHEL. However 6.1 is ok. We need it to support reporting IPv6 addressed during registration to RHN and RHN Satellite.
Comment 15 Neil Horman 2011-02-28 11:45:24 EST
David, has built the latest python-ethtool into brew and tagged it, which contains the functionality requested by this bz
Comment 16 David Sommerseth 2011-02-28 13:39:41 EST
(In reply to comment #15)
> David, has built the latest python-ethtool into brew and tagged it, which
> contains the functionality requested by this bz

Please beware that this is most likely not the last build for RHEL6.  David Malcolm and I have been looking at several stability fixes.  These fixes should be included as well before we release them.  The git tree will be updated as soon as things settles down.
Comment 20 errata-xmlrpc 2011-05-19 10:25:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0770.html

Note You need to log in before you can comment on or make changes to this bug.