Bug 605561 - Traceback from file /tmp/anamon after manual install via vnc
Summary: Traceback from file /tmp/anamon after manual install via vnc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: scheduler   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
low vote
Target Milestone: 0.9.4
Assignee: Dan Callaghan
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
: 602299 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 09:32 UTC by Igor Zhang
Modified: 2012-10-11 23:50 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 23:50:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Igor Zhang 2010-06-18 09:32:23 UTC
Description of problem:
Traceback from file /tmp/anamon after a manual install via vnc from beaker

Version-Release number of selected component (if applicable):
RHEL6.0-Beta1-4.1_nfs-AP-x86_64 

How reproducible:
Seems it's every time.

Steps to Reproduce:
On the machine web page,
1. choose distro RHEL6.0-Beta1-4.1_nfs-AP-x86_64;
2. type keyword manual in field "KickStart MetaData";
3. append keyword vnc to the string in field "Kernel Options (Install)";
4. keep others as default and provision the system;
5. after the manual install and reboot in vncviewer, we can see the Traceback in console window.
  
Actual results:
Message snips:
Press <enter> for a shell
04:54:54 Starting graphical installation.
disabling swap...
	/dev/dm-0
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0 LOOP_CLR_FD failed: 16
	/proc done
	/dev/pts done
	/sys done
	/mnt/stage2 done
	/selinux done
	/mnt/sysimage/boot done
	/mnt/sysimage/dev/pts done
	/mnt/sysimage/dev/shm done
	/mnt/sysimage/dev done
	/mnt/sysimage/home done
	/mnt/sysimage/proc/bus/usb done
	/mnt/sysimage/proc done
	/mnt/sysimage/sys done
	/mnt/sysimage/test1 done
	/mnt/sysimage/selinux done
Traceback (most recent call last):
  File "/tmp/anamon", line 273, in <module>
    anamon_loop()
  File "/tmp/anamon", line 215, in anamon_loop
    if alog.seen("step installpackages$") or (sysimage.stable() and watch.exists()):
  File "/tmp/anamon", line 154, in stable
    self.update()
  File "/tmp/anamon", line 136, in update
    fd = open('/proc/mounts')
IOError: [Errno 2] No such file or directory: '/proc/mounts'
	/mnt/sysimage done
waiting for mdraid sets to become clean...
sending termination signals...done
sending kill signals...done
rebooting system
Restarting system.


Expected results:
No Traceback

Additional info:
Although there is a traceback, system can boot successfully and run normally.

Comment 2 RHEL Product and Program Management 2010-06-18 09:53:15 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Lumens 2010-06-18 14:16:17 UTC
anaconda is not responsible for anamon.

Comment 4 Dan Callaghan 2012-09-13 21:54:10 UTC
*** Bug 602299 has been marked as a duplicate of this bug. ***

Comment 5 Dan Callaghan 2012-09-25 00:42:24 UTC
On Gerrit: http://gerrit.beaker-project.org/1371

Comment 7 Dan Callaghan 2012-10-11 23:50:02 UTC
Beaker 0.9.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.