Bug 605565 - RFC: Allow use of local ISO image to install guest on remote connection
Summary: RFC: Allow use of local ISO image to install guest on remote connection
Status: CLOSED WONTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 09:42 UTC by Nan Zhang
Modified: 2014-07-06 19:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 15:11:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nan Zhang 2010-06-18 09:42:34 UTC
Description of problem:
as subject.

Version-Release number of selected component (if applicable):
virt-manager-0.8.4-4.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Using virt-manager to connect host B on host A (Remote tunnel over SSH
)
2. Create a new guest on host B with host A's virt-manager
3. # ll /var/lib/libvirt/boot/boot.iso
-rw-r--r--. 1 qemu qemu 195035136 Jun 17 00:47 /var/lib/libvirt/boot/boot.iso

Actual results:
Error setting install media location.
Checking installer location failed: Could not find media '/var/lib/libvirt/boot/boot.iso'.

Expected results:
It can be booted up.

Additional info:

Comment 2 RHEL Product and Program Management 2010-06-18 10:13:30 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Cole Robinson 2010-06-21 18:06:01 UTC
If you are trying to use an ISO on Host A to install a guest on Host B, that isn't possible. ISO media must be available on the remote host.

If the ISO is on Host B, it needs to be in a libvirt storage pool. Try moving the ISO to /var/lib/libvirt/images or make /var/lib/libvirt/boot a storage pool using virt-manager.

Comment 4 Justin Clift 2010-06-30 08:37:02 UTC
As a thought, would it be practical to make this work?

Asking because solutions exist whereby a person using a web browser can manage remote servers, and then boot those servers using a virtual CD image (iso) on the local users pc.

  ie Remote management of IBM blade servers using Firefox.  A java applet in
     Firefox communicates with the blade enclosure "controller" software, and
     pipes (?) the iso file to the remote server.  The remote server sees it
     as locally attached CD/DVD.

     I've personally used this approach before, and it generally works pretty
     well with decent LAN connectivity to the servers.  (ie when located at
     the same physical site)

Having the same kind of thing work through virt-manager would be useful.

Comment 5 Cole Robinson 2010-06-30 14:19:05 UTC
Yeah I guess that's a valid RFC, no idea how we would solve it though.

Comment 7 RHEL Product and Program Management 2010-06-30 14:43:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 8 RHEL Product and Program Management 2010-07-15 14:06:56 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 10 Cole Robinson 2010-12-01 15:12:18 UTC
This is unlikely for 6.1, moving to 6.2

Comment 11 Cole Robinson 2011-04-07 16:55:31 UTC
We could use new libvirt volume upload API for this.

Comment 13 Cole Robinson 2011-06-10 21:38:46 UTC
I think libvirt would support this in a way, but exposing this in the UI in a reasonably informative way is still up in the air. Deferring to 6.3 for now.

Comment 15 Cole Robinson 2011-12-09 23:14:39 UTC
Not urgent, and given reduced capacity for virt-manager/virtinst, just moving
this to the upstream tracker.

Comment 17 Cole Robinson 2013-08-17 15:11:06 UTC
While this is a cool idea, I don't think it's ever going to be implemented. Really the only way I can imagine it would work is to upload the ISO to the remote host, and if we are dealing with say a DVD that means a lot of data. I'm fine with just saying 'upload the media on your own, or use a URL install' unless users start suddenly clamoring for it.


Note You need to log in before you can comment on or make changes to this bug.