Bug 605569 - RHEL6 is missing a commandline network configuration tool
RHEL6 is missing a commandline network configuration tool
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Harald Hoyer
Jan Ščotka
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 05:55 EDT by Stefan Assmann
Modified: 2011-03-05 11:58 EST (History)
10 users (show)

See Also:
Fixed In Version: system-config-network-1.6.0.el6.2-1.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2010-06-18 05:55:48 EDT
Description of problem:
Yesterday while setting up a system for SR-IOV testing I realized that system-config-network-* is gone and there seems to be no replacement for it on the commandline. In short this means there's no way of configuring network interfaces on the commandline apart from editing /etc/sysconfig/network-scripts/ifcfg-eth* by hand. It's a big step backwards from RHEL5. What's even worse is the case where one adds network hardware to the system and has no graphical NetworkManager at hand. In that case the only way to get your network card setup is by creating a ifcfg-eth file by hand. Seriously, it's a big problem.

Here's a sample ifcfg-eth0, that the user would have to write for every added network card. There's a lot of stuff you can get wrong.
DEVICE="eth0"
BOOTPROTO="dhcp"
DEFROUTE="yes"
HWADDR="52:54:00:FF:CF:03"
IPV4_FAILURE_FATAL="yes"
IPV6INIT="no"
NAME="System eth0"
NM_CONTROLLED="yes"
ONBOOT="yes"
OPTIONS="layer2"
PEERDNS="yes"
PEERROUTES="yes"
TYPE="Ethernet"
UUID="5fb06bd0-0bb0-7ffb-45f1-d6edd65f3e03"


Maybe there is a tool to do this configuration, so far I spoke to gospo and prarit but they didn't know of any.
Comment 2 RHEL Product and Program Management 2010-06-18 06:13:25 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Dan Williams 2010-06-23 18:41:31 EDT
*** Bug 602265 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2010-06-29 13:17:46 EDT
At least the CLI part of system-config-network is coming back; reassigning to system-config-network to get Fixed In Version updated.
Comment 5 Phil Knirsch 2010-07-06 10:14:15 EDT
system-config-network-tui is back in the trees, so given Devel ACK, added Fixed in Version and put to modified.

Thanks & regards, Phil
Comment 7 Uwe Beck 2010-07-14 03:12:23 EDT
I do not think that this report is a dulicate of Bug 602265.
Like I see at RHEL5 system-config-network-tui the tui do not allow configure
DSL. ISDN can only configure a connection to an internet provider.
We need for ISDN D-cannel callback and use static ip configurations for our
remote support.
All this options allow the system-config-network gui to configure.

system-config-network-tui is only helpful for ethernet interfaces.
Comment 9 Jan Ščotka 2010-08-04 08:02:06 EDT
package inclueded.

Basic sanity test done.
system-config-network-tui-1.6.0.el6.2-1.el6.noarch
contains:
system-config-network
system-config-network-tui
system-config-network-cmd
Comment 10 releng-rhel@redhat.com 2010-11-10 16:43:13 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.