Bug 605599 - "Operation not permitted" message returns when stop vm on write error
"Operation not permitted" message returns when stop vm on write error
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5.z
All Linux
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-06-18 06:58 EDT by Qunfang Zhang
Modified: 2011-10-31 03:10 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-31 03:10:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2010-06-18 06:58:04 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kvm-83-164.el5_5.12

How reproducible:
Always

Steps to Reproduce:
1.create a new qcow2 image (vdisk) on nfs server.
#mount -o soft,timeo=1,retrans=1  10.66.91.195:/home/exports /opt
#qemu-img create -f qcow2 /opt/test.qcow2  10G
2.boot an pre-installed kvm guest with the vdisk attached.
/usr/libexec/qemu-kvm -m 2G -smp 2 -drive file=/opt/RHEL5.5-64-qcow2,media=disk,if=ide,index=0,cache=off,werror=stop  -drive file=/opt/test.qcow2,media=disk,if=ide,index=1,cache=off,werror=stop -net nic,model=rtl8139,vlan=0,macaddr=02:00:40:3F:20:4B -net tap,vlan=0,script=/etc/qemu-ifup -uuid 3bcd5af1-9ca7-4975-a88e-9b1e9d378abc -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -cpu qemu64,+sse2 -balloon none -startdate now -name 161-rhel5.5 -vnc :10 -boot c -notify all
3.create partition and file system on vdb inside kvm guest
  #fdisk /dev/hdb
  #mkfs.ext3 /dev/hdb1
4.#mount /dev/hdb1 /mnt
5.copy a large file to /mnt directory
  #cp /root/RHEL5.4-Server-20090819.0-x86_64-DVD.iso  /mnt 
6.on the nfs server . stop the service
   #service nfs stop
7.on the kvm host. wait the nfs connection time out.
8. start and  stop nfs server for lots of iterations.


 
Actual results:
Results (part):

(qemu) qcow2: free_clusters failed: Input/output error

(qemu)
(qemu)
(qemu) info status
VM status: running
(qemu) # VM is stopped due to disk write error: ide0-hd1: Input/output error

(qemu) info status
VM status: paused

(qemu) c


(qemu) # VM is stopped due to disk write error: ide0-hd1: Input/output error

(qemu) c
(qemu)
(qemu) info status
VM status: running
(qemu) info status
VM status: running
(qemu)
(qemu) info status
VM status: running
(qemu) ide_dma_cancel: aiocb still pendingide_dma_cancel: BM_STATUS_DMAING still pendingbdrv_write ret=-5
qcow2: free_clusters failed: Input/output error
# VM is stopped due to disk write error: ide0-hd1: Input/output error

(qemu)
(qemu) info status
VM status: paused
(qemu) c

qemu) info status
VM status: paused
(qemu)
(qemu) # VM is stopped due to disk write error: ide0-hd1: Input/output error
# VM is stopped due to disk write error: ide0-hd1: Operation not permitted

(qemu) info status
VM status: paused
(qemu) c
(qemu) info status
VM status: paused
(qemu) # VM is stopped due to disk write error: ide0-hd1: Operation not permitted
# VM is stopped due to disk write error: ide0-hd1: Input/output error


Expected results:


Additional info:
Comment 3 RHEL Product and Program Management 2011-01-11 15:27:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 17:52:04 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 6 Ronen Hod 2011-10-31 03:10:07 EDT
Since we didn't find the capacity to fix it for 5.8, it doesn't make sense to continue dragging it to the next version. Closing.

Note You need to log in before you can comment on or make changes to this bug.