Bug 605605 - smoltGui is in smolt-gui, but its man page is in smolt
smoltGui is in smolt-gui, but its man page is in smolt
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 07:15 EDT by Andre Robatino
Modified: 2012-12-28 23:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-28 23:25:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2010-06-18 07:15:29 EDT
Description of problem:
The man page for smoltGui is in the smolt package.  But the executable itself is in the smolt-gui package.  The same issue exists in F13 and probably earlier versions of Fedora.

Version-Release number of selected component (if applicable):
smolt-1.4.2.2-1.fc14.noarch
smolt-gui-1.4.2.2-1.fc14.noarch

How reproducible:
always

Additional info:
Two possible solutions: either 1) move the man page into the smolt-gui package, or 2) just get rid of the smolt-gui package and merge its contents into the smolt package.  I favor the second solution for the following reasons:
1) The size of the smolt-gui package is negligible compared to the smolt package, so there doesn't seem to be much benefit from the separation.
2) I've always disliked the fact that the default choice of "Do not send profile" during firstboot is second-guessed, but I can understand the desire to not just let users click through without careful consideration, given that right now, that's the only place most people will enable smolt.  If the present contents of smolt-gui were installed by default, more users might enable smolt after the install, since they could see the Smolt entry in the GUI.  This would make it less important to catch people during firstboot, so maybe the default choice wouldn't have to be second-guessed any more.  By merging smolt-gui into smolt, this would happen automatically (since smolt is already installed by default).
Comment 1 Andre Robatino 2010-06-18 07:38:17 EDT
Correction: just noticed that SmoltGui in smolt-gui is a symlink to /usr/share/smolt/client/smoltGui.py which is in smolt.
Comment 2 Bug Zapper 2010-07-30 08:09:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora Admin XMLRPC Client 2011-02-08 16:14:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Andre Robatino 2012-12-28 23:25:11 EST
Closing since smolt is dead.

Note You need to log in before you can comment on or make changes to this bug.