Bug 60563 - Configure/Compile of Kernel w/o SMP w/ APCI in 2.4.9-31
Configure/Compile of Kernel w/o SMP w/ APCI in 2.4.9-31
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-01 12:49 EST by Mike 'Fox' Morrey
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 16:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 'Fox' Morrey 2002-03-01 12:49:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
When using "menuconfig" to configure the kernel, and I enable "APIC support on 
uniprocessors", without having SMP enabled, when I go to compile (make 
bzImage), the make errors out with:
arch/i386/kernel/kernel.o(.text.init+0x472f): undefined reference to
`have_acpi_tables'
arch/i386/kernel/kernel.o(.text.init+0x4761): undefined reference to
`have_acpi_tables'
arch/i386/kernel/kernel.o: In function `get_smp_config':
arch/i386/kernel/kernel.o(.text.init+0x498e): undefined reference to
`config_acpi_tables'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.9-31'
make: *** [vmlinux] Error 2

I'm not too familiar with kernel making, but it LOOKS like that in the SMP 
section, it's looking for ACPI information, when it SHOULD be looking for APCI. 
(I don't even have ACPI (Power Management) enabled.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Make menuconfig, set your options up as normal. If you have an SMP machine, 
turn SMP off (for purpose of this test.) Turn ON the new option "APIC support 
on uniprocessors". 
Then compile the kernel as necessary (make dep/clean/bzImage). It should error 
out.

Actual Results:  > make[1]: *** [kallsyms] Error 1
> make[1]: Leaving directory `/usr/src/linux-2.4.9-31'
> make: *** [vmlinux] Error 2

I dont get a kernel.. If I disable the ACPI, it builds fine.

Expected Results:  To build the kernel with ACPI support on non SMP machines..

Additional info:

Can supply configuration file, and output to make bzImage if necessary. Have 
NOT tried it with make config or make xconfig, may or may not be present there.

Note You need to log in before you can comment on or make changes to this bug.