Bug 605635 - [RFE] Optimize amount of allocated memory by scheduler
Summary: [RFE] Optimize amount of allocated memory by scheduler
Status: CLOSED DUPLICATE of bug 742874
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: 2.1.1
: ---
Assignee: Timothy St. Clair
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-18 12:59 UTC by Martin Kudlej
Modified: 2011-12-08 20:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-11 20:53:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Martin Kudlej 2010-06-18 12:59:55 UTC
Description of problem:
After submission ~1.2M jobs has scheduler in memory almost 3GB. I think after discussion with developers that It could be possible optimize this huge memory allocation.

Very simple example of job:
Universe=vanilla
Executable=/bin/sleep
Arguments=10
Queue 1000000

Version-Release number of selected component (if applicable):
condor-7.4.3-0.19.el5

Please feel free to change target milestone.

Comment 1 Martin Kudlej 2010-06-18 13:02:30 UTC
Here are examples that scheduler crash because it reach 3GB of memory which is border of OS with PAE kernel. Please see #603657 #603658

Comment 2 Timothy St. Clair 2011-10-11 20:53:21 UTC

*** This bug has been marked as a duplicate of bug 742874 ***


Note You need to log in before you can comment on or make changes to this bug.