Bug 605690 - Update Blacklist Exception example for RHEL 6
Summary: Update Blacklist Exception example for RHEL 6
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-DM_Multipath (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact:
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks: 549824
TreeView+ depends on / blocked
 
Reported: 2010-06-18 14:59 UTC by Steven J. Levine
Modified: 2010-11-11 15:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 15:27:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven J. Levine 2010-06-18 14:59:24 UTC
Description of problem:

RHEL 6 feedback from IBM on the Installation Guide included a note about the DM-Multipath manual. From Rudi Landmann:

Hi Steven:

Tucked into the end of a large batch of IBM feedback on the Installation Guide was this one small nugget for your DM Multipath book (in square brackets at the end of the excerpt)

Cheers
Rudi

==================
RHEL6 DM Multipath
==================
4.2.4 Blacklist Exceptions
You can use the blacklist_exceptions section of the configuration file to enable
multipathing on devices that have been blacklisted by default. For example, by default,
devices with vendor = "IBM" and product = "S/390.*" are blacklisted since usually DASD
devices are used for local storage. If you do need to enable multipathing on these devices,
uncomment the following lines in the configuration file:
blacklist_exceptions {
device {
vendor "IBM"
product "S/390.*"
}
}

[[RHEL6 should have HyperPAV, so DASDs should probably never be used with DM-MP
and therefore this suggested blacklist exception is not a good example?!]]

Comment 2 RHEL Product and Program Management 2010-06-18 15:23:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Steven J. Levine 2010-10-12 20:43:23 UTC
Ben:

This completely slipped through the cracks for me -- sorry -- I should have asked about this long ago. Are you able to provide me with a better example for blacklist exceptions than this?

This bug refers to this example:

http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/DM_Multipath/blacklist_exceptions.html

-Steven

Comment 4 Ben Marzinski 2010-10-13 19:53:38 UTC
There are no default blacklisted devices that you can just swap out DASDs for.

Probably a better example of using blacklist exceptions would be to say something like:

For example, if you have a large number of devices and only want to multipath one of them (with the wwid of 3600d0230000000000e13955cc3757803), instead of individually blacklisting each of the devices except the one you want, you could instead blacklist all of them, and then only allow the one you want by adding the following lines to /etc/multipath.conf

blacklist {
        wwid "*"
}

blacklist_exceptions {
        wwid "3600d0230000000000e13955cc3757803"
}

Comment 5 Steven J. Levine 2010-10-13 19:56:54 UTC
Thanks Ben. As far as I know at this moment, this was the very last piece of RHEL 6 DM-Multipath information I was waiting for and after I make this update I'm good to go.

Barring other issues arising at this point, but unless they are major dangerous urgent things they will probably wait for the next revision of the document.

Thanks for your help.

Comment 6 Steven J. Levine 2010-10-13 21:57:50 UTC
I have updated the document with Ben's new example so I am moving this bug to MODIFIED.

Comment 9 releng-rhel@redhat.com 2010-11-11 15:27:43 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.