Bug 605706 - initscript packaging
Summary: initscript packaging
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: edac-utils (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
high
medium
Target Milestone: rc
: ---
Assignee: Mauro Carvalho Chehab
QA Contact: Alex Sersen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 633349 579073
TreeView+ depends on / blocked
 
Reported: 2010-06-18 15:20 UTC by Karel Volný
Modified: 2013-11-01 01:33 UTC (History)
6 users (show)

Fixed In Version: edac-utils-0.9-11.2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 20:20:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Volný 2010-06-18 15:20:44 UTC
Description of problem:
The .spec file for edac-utils does not follow packaging guidelines.
Please see https://fedoraproject.org/wiki/Packaging/SysVInitScript#Initscript_packaging

1. The .spec is missing dependencies:
Requires(post): chkconfig
Requires(preun): chkconfig
Requires(preun): initscripts

2. To be honest, I really do not understand the condition
if [ $1 = 1 ]; then
in %post ... the guidelines suggest to run chkconfig --add unconditionally

3. The .spec is missing
%postun
if [ "$1" -ge "1" ] ; then
    /sbin/service <script> condrestart >/dev/null 2>&1 || :
fi

As far as I understand the docs, reloading the service after update makes sense, because /etc/edac/labels.db may get updated and thus the change wouldn't get applied if reload is not present.

Comment 2 RHEL Product and Program Management 2010-06-18 15:43:27 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Mauro Carvalho Chehab 2010-06-30 04:13:14 UTC
New SysV script added at: edac-utils-0.9-11.2.el6.src.rpm

Comment 8 releng-rhel@redhat.com 2010-11-10 20:20:53 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.