Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 605722 - [abrt] crash in liferea-1:1.6.3-1.fc13: raise: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
[abrt] crash in liferea-1:1.6.3-1.fc13: raise: Process /usr/bin/liferea was k...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
abrt_hash:268b281141548998e72d1a08108...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 11:51 EDT by Juankof
Modified: 2010-10-13 12:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 12:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (66.31 KB, text/plain)
2010-06-18 11:51 EDT, Juankof
no flags Details

  None (edit)
Description Juankof 2010-06-18 11:51:08 EDT
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/liferea
component: liferea
crash_function: raise
executable: /usr/bin/liferea
global_uuid: 268b281141548998e72d1a08108acfebfdffbd7b
kernel: 2.6.33.5-124.fc13.i686.PAE
package: liferea-1:1.6.3-1.fc13
rating: 4
reason: Process /usr/bin/liferea was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)
Comment 1 Juankof 2010-06-18 11:51:18 EDT
Created attachment 425163 [details]
File: backtrace
Comment 2 Juankof 2010-06-23 20:07:42 EDT
Package: liferea-1:1.6.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Crashed reading feeds
2.
3.
Comment 3 martygeek 2010-06-26 21:08:26 EDT
Package: liferea-1:1.6.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.hell, I don't know. it randomly crashes on clicking a headline
2.
3.


Comment
-----
read the headlines
clicked a headline
it crashed.
Comment 4 alexp 2010-06-27 21:33:43 EDT
Package: liferea-1:1.6.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


Comment
-----
ran liferea on a random slashgear item
Comment 5 Tom Georgoulias 2010-07-01 19:10:56 EDT
Package: liferea-1:1.6.3-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.  Don't know, but it happens so much that I would love for a few tips on what I can do to better isolate the cause.
2.
3.
Comment 6 Steven M. Parrish 2010-07-13 18:26:33 EDT
Liferea 1.6.4 has been pushed to stable.  Please upgrade to this latest version and see if it corrects this issue.  If there is no update to this bug within 30 days will close as WORKSFORME.

Thanks
Comment 7 alexp 2010-07-14 22:41:11 EDT
1.6.4 still crashes for me- invariably when I click on a link to an html page.
Comment 8 alexp 2010-07-15 00:44:54 EDT
I should have been more specific in my prior comment:

I get crashes when I select "Open links in liferea's window" as my browser, with the other two check boxes in that section unchecked ("disable JavaScript", "enable browser plugins").

I don't get crashes (so far) when I use Firefox as my browser.
Comment 9 martygeek 2010-07-15 08:18:33 EDT
I tried to isolate the causes of the bug and provide some decent crash dumps and/or debug logs. 

I've been running liferea for weeks from a terminal using the following :

$> liferea --debug-all &

Apparently, whatever it does in debug-all mode prevents crashes. Haven't had a crash since. Now I have already just re-written my menu link to include the debug switch and everything's fine.  It's not, because the output in debug-all mode is copious - and frequently gives errors such as:

   GUI: Fatal: no node with id "cahgohd" found!

But the GUI keeps right on humming along and never misses a beat or crashes. 

I've given up on looking for a cause. Now I just read the RSS feeds like I wanted to and let the messages fly off into the bit bucket.

Cheers,
Marty
Comment 10 Steven M. Parrish 2010-10-13 12:41:31 EDT
Liferea 1.6.5 has been submitted for testing on F12/F13/F14.  Closing this bug for now.  Please install the new update and if the problem returns feel free to reopen this report with additional information

Note You need to log in before you can comment on or make changes to this bug.