Bug 605734 - initscript actions
initscript actions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: edac-utils (Show other bugs)
6.0
All Linux
high Severity medium
: rc
: ---
Assigned To: Mauro Carvalho Chehab
Alex Sersen
:
Depends On:
Blocks: 633349 579073 632665
  Show dependency treegraph
 
Reported: 2010-06-18 12:15 EDT by Karel Volný
Modified: 2013-10-31 21:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: edac-utils-0.9-11.2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 632665 (view as bug list)
Environment:
Last Closed: 2010-11-10 15:20:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New EDAC SysV script (1.14 KB, application/octet-stream)
2010-06-22 20:18 EDT, Mauro Carvalho Chehab
no flags Details

  None (edit)
Description Karel Volný 2010-06-18 12:15:50 EDT
the initscript does not implement some mandatory actions, it does not implement some actions correctly, and does not report correct status

please see https://fedoraproject.org/wiki/Packaging/SysVInitScript

1) the initscript does not implement 'condrestart'

2) the initscript does not implement 'try-restart'

3) the initscript does not implement 'force-reload'

4) running "service edac status" after "service edac stop" returns 0 instead of 3

5) running "service edac reload" on a stopped service returns 0 instead of 7 and restarts the service

6) for invalid arguments, instead of returning error message and status code 2, the initscript prints usage message and returns 0 - but usage message should be printed only if run without arguments or with "usage" argument

7) running the initscript as non-root user does not return error and status code 4 (except for usage and status, it should be allowed), but it tries to perform the actions which leads to permission denial errors
Comment 2 RHEL Product and Program Management 2010-06-18 12:43:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Mauro Carvalho Chehab 2010-06-22 19:39:10 EDT
(In reply to comment #0)

> 4) running "service edac status" after "service edac stop" returns 0 instead of
> 3
> 
> 5) running "service edac reload" on a stopped service returns 0 instead of 7
> and restarts the service

Such return codes wouldn't make any sense on this case. This script should not
be different than the one provided for bluetooth, where only a start method is
defined:

start()
{
	echo -n $"Enabling Bluetooth devices:"
	udevadm trigger --subsystem-match=bluetooth
	echo ""
	return 0
}

stop()
{
	# FIXME If somebody figures out how to disable the K* script
	echo -n "Stopping Bluetooth services:"
	echo ""
	return 0
}

It is just the same case: we just need to run edac-ctl during start method,
in order to load some parameters at the corresponding kernel driver. This script doesn't start any deamon that needs to be stopped. I think I'll rewrite
the init script to look more like the above, adding some fake methods for all
those restart methods that will just call edac-ctl whatever argument provided,
except for stop and usage.
Comment 4 Mauro Carvalho Chehab 2010-06-22 20:18:37 EDT
Created attachment 426119 [details]
New EDAC SysV script

New script that fulfills all requirements stated at:
https://fedoraproject.org/wiki/Packaging/SysVInitScript#Initscripts_on_the_filesystem

Since this script just sends some data to EDAC kernel driver, there's no stop action, nor there is a "daemon status". So, all actions that asks for reload will just do the same action as "start": send the new memory labels table to the Kernel driver. "stop" and "status" will just return 0, as there's no way (nor make sense) to stop a non-daemon process.
Comment 6 Mauro Carvalho Chehab 2010-06-30 00:13:24 EDT
New SysV script added at: edac-utils-0.9-11.2.el6.src.rpm
Comment 15 releng-rhel@redhat.com 2010-11-10 15:20:55 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.