Bug 605759 - Moblin Crashes on Start
Moblin Crashes on Start
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 13:42 EDT by Allen Zhu
Modified: 2010-07-11 16:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-11 16:05:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached .xsession-errors.old File - Mentioned in Description (30.35 KB, application/x-trash)
2010-06-18 13:42 EDT, Allen Zhu
no flags Details

  None (edit)
Description Allen Zhu 2010-06-18 13:42:25 EDT
Created attachment 425200 [details]
Attached .xsession-errors.old File - Mentioned in Description

Description of problem:

On a brand new Fedora 13 install, Moblin crashes upon login from the Login Screen. After clicking Log In, the cursor changes a few times, you see three quick messages from Network Manager in the top right corner, and Moblin flashes up for a quick second before the screen goes black and goes back to the Login Screen. 

In the Automatic Bug Reporting Tool, you can see three crashes, of, in order of which they occurred:

(1) /usr/libexec/mission-control-5
(2) /usr/libexec/bognor-regis-daemon
(3) /usr/bin/mutter

These three crashes show up in ABRT every time I attempt to login to Moblin. There are also quite a few errors in the .xsession-errors.old file, which I have attached. I have not yet reported these three crashes due to 50+ debuginfo files to download, but I can if you wish me to.

Version-Release number of selected component (if applicable):

telepathy-mission-control-1:5.4.0-1.fc13
bognor-regis-0.6.0-0.1.fc13
mutter-mbl-2.28.1_0.12-1.fc13

If you'd like, I can provide the versions for all of the packages in the YUM Group moblin-desktop.

How reproducible:

This occurs every time I attempt to login to Moblin.

Steps to Reproduce:
1. Turn on your computer.
2. Login to Fedora, selecting Moblin as your Desktop Environment.
  
Actual results:

Moblin crashes, as explained above.

Expected results:

Moblin should pop up successfully, as like it did when I installed it in Fedora 12.

Additional info:

N/A
Comment 1 Peter Robinson 2010-06-18 13:54:49 EDT
What graphics card do you have and what Xorg drivers are you using?
Comment 2 Allen Zhu 2010-06-18 14:27:23 EDT
I have an ATI Radeon X1050; how do you find out which Xorg drivers I'm using?

Thanks,

Allen
Comment 3 Allen Zhu 2010-06-19 13:24:56 EDT
Based on https://fedoraproject.org/wiki/Xorg/Debugging, it seems like I'm using the Radeon driver under the xorg-x11-drv-ati package. Does this help?
Comment 4 Peter Robinson 2010-06-20 07:27:41 EDT
(In reply to comment #3)
> Based on https://fedoraproject.org/wiki/Xorg/Debugging, it seems like I'm using
> the Radeon driver under the xorg-x11-drv-ati package. Does this help?    

Yes, its likely its a crash in the ATI driver. The mutter crash is the one that kills moblin, the other 2 are known but won't take Moblin down. Is there an associated ABRT BZ crash that goes with the mutter crash?
Comment 5 Allen Zhu 2010-06-21 01:14:35 EDT
Well, like I mentioned in the Description, I haven't reported yet the three crashes that always occur in this order:

(1) /usr/libexec/mission-control-5;
(2) /usr/libexec/bognor-regis-daemon (About 1-2 seconds later after #1);
(3) /usr/bin/mutter (About 20-25 seconds later after #2);

because of the 50+ debuginfo files to download. I'm going to report all three of them up now in the same order as listed above.

I tried logging in to Moblin again tonight, and the desktop actually came up and I was able to play with it for about 5 seconds before the screen blanked again...

I'll the post the three bug ID numbers once I'm done. I'd really like to see this problem solved.

Thanks for your help!
Comment 6 Allen Zhu 2010-06-21 01:19:47 EDT
I have all three reported. The first and third ones were new, while the second one was already reported according to ABRT.

Here's the three links in the same order as listed in Comment 5 - I've added them also under "See Also" at the top:

(1) https://bugzilla.redhat.com/show_bug.cgi?id=606195
(2) https://bugzilla.redhat.com/show_bug.cgi?id=596309
(3) https://bugzilla.redhat.com/show_bug.cgi?id=606196

Thanks!
Comment 7 Peter Robinson 2010-06-21 07:12:56 EDT
Thanks, will cross reference some other bugs I have an update each one appropriate.
Comment 8 Allen Zhu 2010-07-10 19:34:45 EDT
Well, I've given up on trying Moblin on Fedora. I've removed all of the packages from my system, since I can't update my system through yum because of a known dependency problem.

Here's the output:

Error: Package: moblin-panel-people-0.0.10-4.fc13.x86_64 (fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
Error: Package: anjal-0.3.2-1.fc13.x86_64 (fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
Error: Package: moblin-panel-myzone-0.0.13-2.fc13.x86_64 (fedora)
           Requires: libedataserver-1.2.so.11()(64bit)
           Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

And it seems like we're having trouble getting to the bottom of this either, since I haven't heard back from you since June 25 (https://bugzilla.redhat.com/show_bug.cgi?id=606196#c4). 

Thanks for your help, though!

P.S. I don't know if I should close this bug or any of the other three, so I'm leaving it up to you.
Comment 9 Peter Robinson 2010-07-11 04:05:01 EDT
(In reply to comment #8)
> Well, I've given up on trying Moblin on Fedora. I've removed all of the
> packages from my system, since I can't update my system through yum because of
> a known dependency problem.
> 
> Here's the output:
> 
> Error: Package: moblin-panel-people-0.0.10-4.fc13.x86_64 (fedora)
>            Requires: libedataserver-1.2.so.11()(64bit)
>            Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
> Error: Package: anjal-0.3.2-1.fc13.x86_64 (fedora)
>            Requires: libedataserver-1.2.so.11()(64bit)
>            Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
> Error: Package: moblin-panel-myzone-0.0.13-2.fc13.x86_64 (fedora)
>            Requires: libedataserver-1.2.so.11()(64bit)
>            Available: evolution-data-server-2.30.1-2.fc13.x86_64 (fedora)
>  You could try using --skip-broken to work around the problem
>  You could try running: rpm -Va --nofiles --nodigest

If you enable the updates-testing repository that problem will go away.

> And it seems like we're having trouble getting to the bottom of this either,
> since I haven't heard back from you since June 25
> (https://bugzilla.redhat.com/show_bug.cgi?id=606196#c4). 

Well I have around 300+ bugs in my queue and I do this in my spare time. 

> Thanks for your help, though!
> 
> P.S. I don't know if I should close this bug or any of the other three, so I'm
> leaving it up to you.    

Well if you don't want to enable updates-testing to fix the above bug and aren't going to re-test please close it off. There are some known GL problems with ATI cards at the moment which cause crashes. Its improving.
Comment 10 Allen Zhu 2010-07-11 16:05:43 EDT
I'm sorry if I offended you; I didn't mean to. I understand - without the support of the community, open source projects would never be as influential and important as they are today.

Thanks again for your help! 

I'm going to close this bug off and the mutter one (https://bugzilla.redhat.com/show_bug.cgi?id=606196). The first and third ones (https://bugzilla.redhat.com/show_bug.cgi?id=606195 and https://bugzilla.redhat.com/show_bug.cgi?id=596309, respectively) are closed and not reported by me respectively.

Note You need to log in before you can comment on or make changes to this bug.