Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 605763 - Failures in long cluster_tests.test_management
Failures in long cluster_tests.test_management
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
beta
All Linux
urgent Severity urgent
: 1.3
: ---
Assigned To: Alan Conway
Frantisek Reznicek
:
: 606324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 14:08 EDT by Alan Conway
Modified: 2015-11-15 20:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 10:35:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2010-06-18 14:08:14 EDT
Description of problem: 

Broker dies in cluster_tests test_managment with
      cluster1-25: 2010-06-18 11:31:22 critical Modified cluster state outside of cluster context 

Also seen while testing for this:
      cluster0-3: 2010-06-18 13:57:57 critical Error delivering frames: local error did not occur on all cluster members : invalid-argument: anonymous.mrg32.lab.bos.redhat.com.29284.2: confirmed < (48+0) but only sent < (47+0) (../../cpp/src/qpid/SessionState.cpp:151) (../../cpp/src/qpid/cluster/ErrorCheck.cpp:89)


Version-Release number of selected component (if applicable): r956001

How reproducible: intermittent, seeing errors every 4-5 runs.

Steps to Reproduce:
cd src/tests
. test_env.sh
while run_cluster_tests *.test_management -DDURATION=2; do true; done
  
Actual results: Fails occasionally

Expected results: No failure
Comment 1 Alan Conway 2010-06-22 09:57:27 EDT
Fixed on trunk r956882, release repo: 
http://mrg1.lab.bos.redhat.com/git/?p=qpid.git;a=commitdiff;h=0f5083fda071b089376561b6de3b89a89d0d7823
Comment 2 Alan Conway 2010-06-22 09:58:49 EDT
*** Bug 606324 has been marked as a duplicate of this bug. ***
Comment 3 Frantisek Reznicek 2010-06-30 05:12:34 EDT
The bug 606324 reproducer indicates the problem is solved. Proceeding with current bug reproducer... info back soon

Note You need to log in before you can comment on or make changes to this bug.