Bug 605826 - Excessive logging of common DNS events clogs syslog
Excessive logging of common DNS events clogs syslog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 607906 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 17:06 EDT by josip@icase.edu
Modified: 2013-04-30 19:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: bind-9.7.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-26 23:50:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip@icase.edu 2010-06-18 17:06:49 EDT
Description of problem:
Excessive logging of common DNS events clogs syslog

Version-Release number of selected component (if applicable):
bind-9.7.0-10.P2.fc13.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Default installation
2.
3.
  
Actual results:
Thousands of resolver, lame-server, and edns-disabled messages clog syslog, without contributing useful information.

Expected results:
Only infrequent important messages should go to syslog.

Additional info:
Default behavior of named should change.  Given the current state of the DNS ecosystem, messages in categories resolver, lame-server, edns-disabled, and queries should simply be discarded.  Routine messages should go to the default_debug channel, and only potentially actionable messages should go to the default_syslog channel. 

Please adjust the default /etc/named.conf to use (or include) more practical logging specification, something like the following:

logging {

// Channels default_syslog, default_debug, default_stderr, and null
// should be predefined, but adjust default_debug here

        channel default_debug {
                file "data/named.run";
                severity dynamic;
                print-time yes;
                print-category yes;
                print-severity no;
        };

        category default { default_syslog; };
        category general { default_syslog; };
        category database { default_debug; };
        category security { default_syslog; };
        category config { default_syslog; };
        category resolver { null; };
        category xfer-in { default_syslog; };
        category xfer-out { default_syslog; };
        category notify { default_debug; };
        category client { default_debug; };
        category unmatched { default_debug; };
        category network { default_debug; };
        category update { default_syslog; };
        category update-security { default_syslog; };
        category queries { null; };
        category query-errors { default_debug; };
        category dispatch { default_debug; };
        category dnssec { default_debug; };
        category lame-servers { null; };
        category delegation-only { default_debug; };
        category edns-disabled { null; };
};
Comment 1 Adam Tkac 2010-06-28 07:27:12 EDT
*** Bug 607906 has been marked as a duplicate of this bug. ***
Comment 2 Eddie Lania 2010-06-29 02:26:21 EDT
Which category do those "dns format errors" belong to?
Comment 3 Adam Tkac 2010-06-29 04:01:51 EDT
(In reply to comment #2)
> Which category do those "dns format errors" belong to?    

Errors written in bug #607906 belongs to "resolver" category.
Comment 4 Fedora Update System 2011-02-18 10:30:38 EST
bind-9.7.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc14
Comment 5 Fedora Update System 2011-02-18 10:31:02 EST
bind-9.7.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc15
Comment 6 Fedora Update System 2011-02-18 10:31:23 EST
bind-9.7.3-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc13
Comment 7 Fedora Update System 2011-02-18 20:22:25 EST
bind-9.7.3-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bind'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bind-9.7.3-1.fc14
Comment 8 Fedora Update System 2011-02-26 23:50:11 EST
bind-9.7.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2011-03-01 20:47:05 EST
bind-9.7.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-03-02 22:05:50 EST
bind-9.7.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.