Bug 605845 - kernel-2.6.33.5-124.fc13.x86_64 BUG in drivers/dma/ioat/dma_v2.c: 314
kernel-2.6.33.5-124.fc13.x86_64 BUG in drivers/dma/ioat/dma_v2.c: 314
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-18 18:45 EDT by Chris Li
Modified: 2010-12-23 14:55 EST (History)
11 users (show)

See Also:
Fixed In Version: kernel-2.6.34.7-66.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-09 17:45:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of the kernel oops (1.03 MB, image/jpeg)
2010-06-18 18:45 EDT, Chris Li
no flags Details

  None (edit)
Description Chris Li 2010-06-18 18:45:41 EDT
Created attachment 425262 [details]
Picture of the kernel oops

Description of problem:

Just kernel panic during boot up, after udev have been loaded.
nomodeset or irqpoll does not help.

Version-Release number of selected component (if applicable):

kernel-2.6.33.5-124.fc13.x86_64

How reproducible:

This only happen on my Mac Pro with 8 CPU.

Steps to Reproduce:
1. Just boot up the Fedora kernel it panic.
2.
3.
  
Actual results:

Panic.

Expected results:

Not panic?

Additional info:

Interestingly, I start to see it on the FC 12 kernel since 2.6.32-xxx.
The last good FC12 kernel is a 2.6.31 one. I keep using that one and hope
Fedora fix the problem. Preupgrade to FC 13 works fine. But the FC13
kernel still have this problem.

I can compile my own kernel from Linux's git tree which does not
have this problems. It is the kernel I am using on this machine now.

See the attached images (That crash is using irqpoll option).

The BUG() is pointing at this one:
drivers/dma/ioat/dma_v2.c: 314

		/* when halted due to errors check for channel
		 * programming errors before advancing the completion state
		 */
		if (is_ioat_halted(status)) {
			u32 chanerr;

			chanerr = readl(chan->reg_base + IOAT_CHANERR_OFFSET);
			dev_err(to_dev(chan), "%s: Channel halted (%x)\n",
				__func__, chanerr);
			BUG_ON(is_ioat_bug(chanerr)); <-------------- HERE!
		}

I am only seeing it on my Mac Pro (8 CPU 8G RAM).

If you any any thing from me, please let me know. I am glad to do
some guinea pigs to get it fixed.

Thanks
Comment 1 Alexjan Carraturo 2010-06-23 11:10:37 EDT
I have the same porblem with 2.6.33.5-124 (PAE or NOT). I get ever "kernel panic, unable to mount root hd(0,0).

I saw that there is not intitramfs... does it's normal, or does it's the error?
Comment 2 Stanislaw Gruszka 2010-06-23 12:22:48 EDT
> I can compile my own kernel from Linux's git tree which does not
> have this problems. It is the kernel I am using on this machine now.
[snip]
> If you any any thing from me, please let me know. I am glad to do
> some guinea pigs to get it fixed.

Which upstream version have this bug fixed? Do you have idea what commit it a fix?
Comment 3 Chris Li 2010-06-23 16:30:05 EDT
Alexjan,

Your kernel panic is likely a different one. I can pass mounting HD and
even running udev.

Stanislaw,

I never have a problem with the upstream version of the kernel. It seems a Fedora specific thing. It is possible that my upstream kernel did not load that ioatdma module. Do you know a way to disable loading loatdma from the initramfs for the FC kernel? Another thing I can try is loading ioatdma from the vanilla kernel.
Comment 4 Chris Li 2010-06-23 16:42:42 EDT
Sorry, I was wrong about kernel panic after mount. It crash before mounting
local file systems.

It turn out that if I blacklist ioatdma in /etc/modules.conf/blacklist.conf,
I can make the Fedora kernel work.
Comment 5 Chris Li 2010-06-23 17:23:34 EDT
I verify that loading ioatdma on latest git tree will panic as well.
So this is not a FC kernel problem. FC kernel just load ioatdma by default
while my own test kernel doesn't. I am going to report on the lkml instead.
Comment 6 Alexjan Carraturo 2010-06-24 03:48:57 EDT
@Chris 

The question is that, with the older version of the kernel, Fedora 13 works perfectly on my acer aspire one A110L. 

But with the last kernel (and  I think that the problem is in the absence of the initramfs) it's not able to mount root fs.
Comment 7 Stanislaw Gruszka 2010-06-24 03:53:13 EDT
(In reply to comment #5)
> while my own test kernel doesn't. I am going to report on the lkml instead.    

Good idea. Do not forget CC I/OAT guys from /usr/src/linux/MAINTAINERS file. Let me know if there will be patch available.
Comment 8 Stanislaw Gruszka 2010-06-24 03:58:03 EDT
Alexjan, just cc you to bug 606467, looks that you have the same problem.
Comment 9 moondrake 2010-11-24 22:45:34 EST
I think this is a dupe of 571233.

According to this: http://kerneltrap.org/mailarchive/linux-kernel/2010/7/16/4595075/thread

it should be fixed. I am updating to FC14 and will report back.
Comment 10 Kyle McMartin 2010-12-09 17:45:47 EST
Hi, 

It is indeed fixed in 2.6.35 stable (verified that the patch is in there.) I'll copy the fix for F-13 and close this bug.

Thanks!
 Kyle
Comment 11 Fedora Update System 2010-12-15 09:03:06 EST
kernel-2.6.34.7-66.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kernel-2.6.34.7-66.fc13
Comment 12 Fedora Update System 2010-12-23 14:55:46 EST
kernel-2.6.34.7-66.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.