Bug 60587 - Bringing up a dummy interface causes error message
Summary: Bringing up a dummy interface causes error message
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-01 21:00 UTC by Kambiz Aghaiepour
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 19:40:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kambiz Aghaiepour 2002-03-01 21:00:55 UTC
From Bugzilla Helper:
User-Agent: hippie/0.01 [en] (VGA; U; some O/S)

Description of problem:
Bringing up a dummy interface, though seems to function, has issues with an
error reported upon ifup'ing the interface, IF the NETMASK is set to
255.255.255.255.  This has to be the netmask, as we want to avoid adding network
routes on the dummy interface.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create /etc/sysconfig/network-scripts/ifcfg-dummy0 with the following
content:
DEVICE=dummy0
ONBOOT=yes
IPADDR=a.b.c.d
NETMASK=255.255.255.255

(with a.b.c.d being an actual address of course)

2. run "ifup dummy0"

3. See the output:
RTNETLINK answers: File exists


Actual Results:  The other thing to note (which is different than the 6.2
behavior, which does work by the way) is the routing table entries that are
created.  After upping the interface, the routing table looks like such:

0.0.0.0         0.0.0.0         255.255.255.255 UH       40 0          0 dummy0
192.168.6.0     0.0.0.0         255.255.255.0   U        40 0          0 eth0
172.16.52.0     0.0.0.0         255.255.252.0   U        40 0          0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U        40 0          0 lo
0.0.0.0         192.168.6.51    0.0.0.0         UG       40 0          0 eth0

I would have expected the entry for dummy0 to look like:

a.b.c.d         0.0.0.0         255.255.255.255 UH       40 0          0 dummy0

(where a.b.c.d is that real IP address assigned to the dummy interface and seen
from the output of ifconfig -a)


Expected Results:  Described in "actual results"

Additional info:

Comment 1 Bill Nottingham 2005-09-29 19:40:47 UTC
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.


Note You need to log in before you can comment on or make changes to this bug.