Bug 60597 - screen's default hardstatus line uninformative
screen's default hardstatus line uninformative
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: screen (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
: FutureFeature
Depends On:
Blocks: 60596
  Show dependency treegraph
 
Reported: 2002-03-01 18:20 EST by Mike McLean
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 17:46:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2002-03-01 18:20:27 EST
screen-3.9.9-3  (and others)

It would be nice if screen's default hardstatus were more informative.

Perhaps you could add the following two lines to /etc/screenrc:
defhstatus "^Et"
hardstatus string "[screen %n] %h"

For comparison, the current default is to have defhstatus unset and the
hardstatus line set to "%h".
Comment 1 Phil Copeland 2002-04-15 15:19:05 EDT
Tweaked.
Comment 2 Jens Petersen 2002-07-29 07:08:20 EDT
I would to propose using "%w" instead of "%h" (or at least "%t" in view of
bug 60596 ;-), since having a list of screen windows in the title line is
most useful IMHO.
Comment 3 Mike McLean 2002-07-29 12:33:53 EDT
How about a comprimise?  Change the default defhstatus and hardstatus string
settings in /etc/screenrc to:

defhstatus ""
hardstatus string "[screen %n: %t] %h"

Which for a bash session would result in a title like:

[screen 0: bash] user@host:~/foo
 
Comment 4 Jens Petersen 2002-07-30 03:25:59 EDT
That would be ok, but I think it would be more information having the window
list in the title.
Comment 5 Phil Copeland 2002-08-12 15:10:44 EDT
Ok,.. ahev you two sorted out what you want in this yet?

If not it's going out as is

Phil
=--=
Comment 6 Mike McLean 2002-08-12 16:43:19 EDT
I would prefer

defhstatus ""
hardstatus string "[screen %n%?: %t%?] %h"

(the %?%? suppresses the colon-space when the title is null)

I would rather not keep the screenlist up all the time b/c for many people this
will read "0* bash  1 bash  2 bash  3 bash", which is just not all that helpful.
 People that know enough to manually set the title (^AA) to something
interesting should also know enough to manually get a window list (^Aw).  Those
that really care can edit their .screenrc.

No default can be perfect for every situation, but I really think this one is
the better choice for now.
Comment 7 Phil Copeland 2002-08-12 17:45:57 EDT
ok.. screen-3.9.11-9 is born,.. should be in rawhide in the morning or you can
nab it from beehive/comps/dist/8.0/screen in a few minutes

Phil
=--=
Comment 8 Phil Copeland 2002-08-12 17:59:30 EDT
Closed


Note You need to log in before you can comment on or make changes to this bug.