Bug 605978 - SELinux is preventing /usr/sbin/swat "signal" access .
SELinux is preventing /usr/sbin/swat "signal" access .
Status: CLOSED DUPLICATE of bug 605974
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:3f55240bcab...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-19 14:31 EDT by Wayne Spivak
Modified: 2010-06-21 07:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 07:16:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Spivak 2010-06-19 14:31:24 EDT
Summary:

SELinux is preventing /usr/sbin/swat "signal" access .

Detailed Description:

SELinux denied access requested by swat. It is not expected that this access is
required by swat and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:swat_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                None [ process ]
Source                        swat
Source Path                   /usr/sbin/swat
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           samba-swat-3.4.7-58.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-116.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.14-127.fc12.i686.PAE #1 SMP Fri May 28
                              04:47:04 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sat 19 Jun 2010 02:30:40 PM EDT
Last Seen                     Sat 19 Jun 2010 02:30:40 PM EDT
Local ID                      9bfd830b-862a-48bf-9d86-45efebf25a77
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276972240.401:39567): avc:  denied  { signal } for  pid=27698 comm="swat" scontext=unconfined_u:system_r:swat_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=process

node=(removed) type=SYSCALL msg=audit(1276972240.401:39567): arch=40000003 syscall=37 success=no exit=-13 a0=55db a1=f a2=b15ff4 a3=55db items=0 ppid=26823 pid=27698 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=213 comm="swat" exe="/usr/sbin/swat" subj=unconfined_u:system_r:swat_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,swat,swat_t,unconfined_t,process,signal
audit2allow suggests:

#============= swat_t ==============
allow swat_t unconfined_t:process signal;
Comment 1 Miroslav Grepl 2010-06-21 07:16:28 EDT

*** This bug has been marked as a duplicate of bug 605974 ***

Note You need to log in before you can comment on or make changes to this bug.