Bug 606001 - [abrt] crash in texmaker-1:1.9.9-1.fc13: QTextCodec::fromUnicode: Process /usr/bin/texmaker was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in texmaker-1:1.9.9-1.fc13: QTextCodec::fromUnicode: Process /us...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texmaker (Show other bugs)
(Show other bugs)
Version: 13
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2c279c325a7242ba16d1ad3d3e8...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-19 21:20 UTC by edatva
Modified: 2010-08-20 01:49 UTC (History)
8 users (show)

Fixed In Version: texmaker-2.0-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-20 01:30:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (38.22 KB, text/plain)
2010-06-19 21:20 UTC, edatva
no flags Details

Description edatva 2010-06-19 21:20:53 UTC
abrt 1.1.1 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: texmaker /home/purple/Desktop/paper_in_progress/jun_17/RC.tex
component: texmaker
crash_function: QTextCodec::fromUnicode
executable: /usr/bin/texmaker
global_uuid: 2c279c325a7242ba16d1ad3d3e83d8ff1c47080c
kernel: 2.6.33.5-124.fc13.i686
package: texmaker-1:1.9.9-1.fc13
rating: 4
reason: Process /usr/bin/texmaker was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Comment 1 edatva 2010-06-19 21:20:55 UTC
Created attachment 425385 [details]
File: backtrace

Comment 2 Deji Akingunola 2010-06-21 15:20:31 UTC
This seems to be a bug in qt, re-assigning.

Comment 3 Kevin Kofler 2010-06-21 17:14:35 UTC
> #0  QTextCodec::fromUnicode (this=0x0, str=...) at codecs/qtextcodec.cpp:1195

This means texmaker is trying to call the fromUnicode method on a NULL QTextCodec. This is a bug in texmaker. The offending call is at:

> #1  0x08112e7d in SpellerDialog::SpellingNextWord (this=0x97dd5c0)
>     at spellerdialog.cpp:242

Reassigning back.

Comment 4 Fedora Update System 2010-08-06 18:30:49 UTC
texmaker-2.0-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/texmaker-2.0-1.fc12

Comment 5 Fedora Update System 2010-08-06 18:31:01 UTC
texmaker-2.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/texmaker-2.0-1.fc13

Comment 6 Fedora Update System 2010-08-07 23:21:49 UTC
texmaker-2.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texmaker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/texmaker-2.0-1.fc13

Comment 7 Fedora Update System 2010-08-07 23:26:34 UTC
texmaker-2.0-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update texmaker'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/texmaker-2.0-1.fc12

Comment 8 Fedora Update System 2010-08-20 01:29:51 UTC
texmaker-2.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2010-08-20 01:49:00 UTC
texmaker-2.0-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.