Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 606013 - It is possible to install obsoleted package in some special cases
It is possible to install obsoleted package in some special cases
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: James Antill
BaseOS QE Security Team
:
Depends On:
Blocks: 582655
  Show dependency treegraph
 
Reported: 2010-06-19 19:27 EDT by Šimon Lukašík
Modified: 2014-01-21 01:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 16:27:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2010-06-19 19:27:31 EDT
Description of problem:
Assume these two facts about yum:
 * yum should not install obsoleted package
 * yum should allow install package, which had been obsoleted, but is no longer obsoleted
Then assume this situation:
 * test-obsoletes-0.1-1 obsoletes test-obsoleted
 * test-obsoletes-0.2-2 does NOT obsoletes test-obsoleted
 * test-obsoletes-0.1-1 is installed
Then yum will allow installation of test-obsoleted


Version-Release number of selected component (if applicable):
yum-3.2.27-12.el6

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
package obsoleted by already installed package is installed

Expected results:
probably should not install in this case

Additional info:
Feel free to close as WONTFIX, if caching this rare problem will slow down yum notably. I've just tried to come up with some test cases.
Comment 2 Šimon Lukašík 2010-06-19 19:31:55 EDT
(In reply to comment #0)
> Feel free to close as WONTFIX, if caching this rare problem will slow down yum
s/caching/catching/
Comment 4 RHEL Product and Program Management 2010-06-19 19:52:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 James Antill 2010-06-20 13:20:45 EDT
 Given the text from the test:

:: [   PASS   ] :: Running 'yum --nogpgcheck --disablerepo=\*
--tmprepo=/tmp/tmp.qftcTqJwHe.repo -y install test-obsoleted-0.1-1'
:: [   FAIL   ] :: Checking for the non-presence of test-obsoleted rpm

...this implies that there are no repos. enabled, so this is a simple "yum install" doesn't count installed packages which obsolete (ie. 604080) but for regular install vs. localinstall.
 Am I confused?
Comment 6 Šimon Lukašík 2010-06-21 02:53:07 EDT
Thanks for quick response, I think this is different case than bug 604080. 

Firstly, I see issue 604080 fixed with yum-3.2.27-12.el6. 

And that's not right there are no repos. From what I know '--tmprepo' does not care about '--disablerepo'. So there is that tmprepo, containing:
test-obsoletes-0.1-1
test-obsoletes-0.2-2
test-obsoleted-0.1-1

What I think is going on is (maybe wrong): 
Yum uses newest packages in repo for 'obsoletes' resolution, even if there are installed packages with another obsoletes settings. 

Is it possible? 
-And isn't it insignificant?
Comment 7 RHEL Product and Program Management 2010-07-15 10:47:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 James Antill 2010-09-20 16:27:35 EDT
 Šimon's right, we use the latest available package (not including installed packages) to calculate obsoletes.
 If done in the "right place" it will be a bit slower, but maybe not significant, including the installed packages in this calculation ... however it's hard to get that data there ... which implies we'd have to redo the calculation which is much more likely to be noticable.
 It might still not be the end of the world ... but given this is just a weird test edgecase, I'm going to CLOSE it.

Note You need to log in before you can comment on or make changes to this bug.