Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606034 - libgstshapewipe.so exists in both gstreamer-plugins-bad-free and gstreamer-plugins-good
libgstshapewipe.so exists in both gstreamer-plugins-bad-free and gstreamer-pl...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gstreamer-plugins-bad-free (Show other bugs)
6.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
:
: 606219 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-19 23:41 EDT by Dan Williams
Modified: 2010-11-10 15:36 EST (History)
4 users (show)

See Also:
Fixed In Version: gstreamer-plugins-bad-free-0.10.19-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 15:36:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Williams 2010-06-19 23:41:41 EDT
The recent update of gstreamer-plugins-good appears to provide libgstshapewipe.so, which RHEL6's gstreamer-plugins-bad-free also appears to provide.  This causes the DVD install to exit with the error:

file conflicts: file /usr/lib/gstreamer-0.10/libgstshapewipe.so conflicts between attempted installs of gstreamer-plugins-bad-free-0.10.17-4.el6.i686 and gstreamer-plugins-good-0.10.23-1.el6.i686

I assume libgstshapewipe.so got moved from -bad to -good in the past few months or something.
Comment 1 Dan Williams 2010-06-19 23:42:47 EDT
Maybe we just need an update of gstreamer-plugins-bad-free to something more recent than February 2010.
Comment 2 Benjamin Otte 2010-06-20 07:18:16 EDT
Oh, I wasn't aware that the new plugins-good package was already put into the repos. I rebuilt the other GStreamer packages for WebM, but punted on plugins-bad-free because libvpx wasn't available yet.

I suppose I'll rebuild it without libvpx to get this issue fixed quickly.
Comment 3 Benjamin Otte 2010-06-20 18:08:15 EDT
Built gstreamer-plugins-bad-free-0.10.19-1.el6 that fixes this.
Comment 5 Benjamin Otte 2010-06-21 05:21:36 EDT
*** Bug 606219 has been marked as a duplicate of this bug. ***
Comment 6 Lubos Kocman 2010-06-22 11:06:46 EDT
Hello

Verified on gstreamer-plugins-bad-free-0.10.19-1.el6 
/usr/lib/gstreamer-0.10/libgstshapewipe.so is no longer present in the package.
Comment 7 releng-rhel@redhat.com 2010-11-10 15:36:55 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.