Bug 606039 - SELinux is preventing /usr/bin/tpb "read" access on nvram.
SELinux is preventing /usr/bin/tpb "read" access on nvram.
Status: CLOSED DUPLICATE of bug 560807
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:54f61d19185...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 01:09 EDT by Robert Martin
Modified: 2010-09-20 07:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 08:37:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Martin 2010-06-20 01:09:37 EDT
Summary:

SELinux is preventing /usr/bin/tpb "read" access on nvram.

Detailed Description:

SELinux denied access requested by tpb. It is not expected that this access is
required by tpb and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                xguest_u:xguest_r:xguest_t:s0
Target Context                system_u:object_r:nvram_device_t:s0
Target Objects                nvram [ chr_file ]
Source                        tpb
Source Path                   /usr/bin/tpb
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           tpb-0.6.4-12.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-23.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686
                              #1 SMP Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Fri 18 Jun 2010 06:10:35 PM CDT
Last Seen                     Fri 18 Jun 2010 06:10:36 PM CDT
Local ID                      9f631b39-d16b-43a4-a2d7-ed6249eec8e7
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1276902636.99:29): avc:  denied  { read } for  pid=4043 comm="tpb" name="nvram" dev=devtmpfs ino=5470 scontext=xguest_u:xguest_r:xguest_t:s0 tcontext=system_u:object_r:nvram_device_t:s0 tclass=chr_file

node=(removed) type=SYSCALL msg=audit(1276902636.99:29): arch=40000003 syscall=5 success=no exit=-13 a0=97ea858 a1=800 a2=7 a3=97eaa98 items=0 ppid=1 pid=4043 auid=502 uid=502 gid=504 euid=502 suid=502 fsuid=502 egid=504 sgid=504 fsgid=504 tty=(none) ses=1 comm="tpb" exe="/usr/bin/tpb" subj=xguest_u:xguest_r:xguest_t:s0 key=(null)



Hash String generated from  catchall,tpb,xguest_t,nvram_device_t,chr_file,read
audit2allow suggests:

#============= xguest_t ==============
allow xguest_t nvram_device_t:chr_file read;
Comment 1 Miroslav Grepl 2010-06-21 08:37:57 EDT

*** This bug has been marked as a duplicate of bug 560807 ***

Note You need to log in before you can comment on or make changes to this bug.