Bug 60605 - PHP -4.0.6-9.7.1.i386.rpm breaks mod_php.
Summary: PHP -4.0.6-9.7.1.i386.rpm breaks mod_php.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-02 01:50 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 10:36:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-02 01:50:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
Installation vi rpm -Fvh of php-4.0.6-9.7.1.i386.rpm breaks latest version of
mod_php for RedHat 7.1 and 7.0 rendering mod_php unusable and apache unable to
be started because of the following error.

Starting httpd: Syntax error on line 256 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: libmm.so.11: cannot open
shared object file: No such file or directory


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Fvh php-4.0.6-9.7.1.i386.rpm php-manual-4.0.6-9.7.1.i386.rpm
php-mysql-4.0.6-9.7.1.i386.rpm

2. /etc/init.d/httpd restart
	

Actual Results:  Starting httpd: Syntax error on line 256 of
/etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: libmm.so.11: cannot open
shared object file: No such file or directory


Expected Results:  httpd start and run.

Additional info:

Comment 1 Phil Copeland 2002-03-04 17:50:07 UTC
What version of mm? (rpm -q mm)

Also the path looks wrong. I'd have expected to find libphp4.so in
/usr/lib/apache/libphp4.so, not in /etc/httpd/modules

Phil
=--=


Comment 2 Need Real Name 2002-03-05 02:53:43 UTC
per requested info in e-mail

libphp4.so is in usr/lib/apache.... but the error message still stands as above.
 mm is not installed.  Nor did I get an error message related to needing mm when
I did rpm -Fvh rpmname.rpm.

James

Comment 3 Phil Copeland 2002-03-05 08:49:47 UTC
You should install mm
(up2date mm) or grab mm*.rpm from ftp

Phil
=--=

Comment 4 Need Real Name 2002-03-05 09:46:51 UTC
mm is now installed.  Still have the same problems with php upgrades. If I
install the above rpm's mod_php is broken. PHP-nuke and some other programs on
boxes I've yet to upgrade need mod_php.  Sorry to be such a pain.......looking
more and more like I'll have to build it myself.

Comment 5 Stefan Stefanov 2002-03-13 10:36:55 UTC
Similar problem here. Redhat 7.1 upgraded with up2date to: apache-1.3.22-1.7.1
and php-4.0.6-9.7.1. 

The problem is that apache processes die with the following error:
[Wed Mar 13 10:56:00 2002] [notice] child pid 17698 exit signal Segmentation
fault (11)


Comment 6 Phil Copeland 2002-05-09 19:27:35 UTC
Errata php-4.0.6-13



Note You need to log in before you can comment on or make changes to this bug.