Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 606070 - SELinux empêche l'accès en "getattr" à /usr/bin/kdm on /boot/grub/grub.co
SELinux empêche l'accès en "getattr" à /usr/bin/kdm on /boot/grub/grub.co
Status: CLOSED DUPLICATE of bug 540213
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f07e7d16d3b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 07:12 EDT by altadeos
Modified: 2010-07-31 20:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 08:19:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description altadeos 2010-06-20 07:12:43 EDT
Résumé:

SELinux empêche l'accès en "getattr" à /usr/bin/kdm on /boot/grub/grub.co

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux a refusé l'accès demandé par kdm. Il n'est pas prévu que cet accès
soit requis par kdm et cet accès peut signaler une tentative d'intrusion. Il
est également possible que cette version ou cette configuration spécifique de
l'application provoque cette demande d'accès supplémenta

Autoriser l'accès:

Vous pouvez créer un module de stratégie locale pour autoriser cet accès -
lisez la FAQ (http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Merci de
remplir un rapport de bogue.

Informations complémentaires:

Contexte source               system_u:system_r:xdm_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:boot_t:s0
Objets du contexte            /boot/grub/grub.conf [ file ]
source                        kdm
Chemin de la source           /usr/bin/kdm
Port                          <Inconnu>
Hôte                         (supprimé)
Paquetages RPM source         kdm-4.4.4-1.fc13
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.7.19-23.fc13
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (supprimé)
Plateforme                    Linux (supprimé) 2.6.33.5-124.fc13.i686 #1 SMP Fri Jun
                              11 09:48:40 UTC 2010 i686 i686
Compteur d'alertes            2
Première alerte              dim. 20 juin 2010 13:06:11 CEST
Dernière alerte              dim. 20 juin 2010 13:09:30 CEST
ID local                      5789cf83-fe19-4153-8472-f7cc41685d3c
Numéros des lignes           

Messages d'audit bruts        

node=(supprimé) type=AVC msg=audit(1277032170.963:17): avc:  denied  { getattr } for  pid=1554 comm="kdm" path="/boot/grub/grub.conf" dev=sda1 ino=65046 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:boot_t:s0 tclass=file

node=(supprimé) type=SYSCALL msg=audit(1277032170.963:17): arch=40000003 syscall=197 success=yes exit=0 a0=d a1=bfd3adb8 a2=73dff4 a3=8c05390 items=0 ppid=1 pid=1554 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm,xdm_t,boot_t,file,getattr
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t boot_t:file getattr;
Comment 1 Miroslav Grepl 2010-06-21 08:19:40 EDT

*** This bug has been marked as a duplicate of bug 540213 ***

Note You need to log in before you can comment on or make changes to this bug.