Bug 606140 - lxpanel width is 1px when "autohide=1" and "widthtype=request"
lxpanel width is 1px when "autohide=1" and "widthtype=request"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
13
i686 Linux
low Severity low
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 17:05 EDT by Dag
Modified: 2012-06-27 23:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 20:19:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dag 2010-06-20 17:05:48 EDT
Description of problem:
I edit "by hand" the panel configuration file (later it will be scripted), with VIM.
When I set a panel "Global" properties:
widthtype=request
autohide=1

When reloading lxpanel... the panel is 1pixel wide, which is unusable.

Version-Release number of selected component (if applicable):
lxpanel-0.5.5-3.fc13.i686

How reproducible:
always

Steps to Reproduce:
1. open the ~/.config/lxpanel/LXDE/panel with vim
2. set "widthtype" value to "request"
3. set "autohide" value to "1"
4. terminate any running instance of lxpanel for your user
5. execute lxpanel
  
Actual results:
The width of the panel is 1 pixel.

Expected results:
The width of the panel must be the addition of the plugins size.

Additional info:
May somone post this bug on lxde bug tracker, beacause I couldn't post it myself.
Comment 1 Christoph Wickert 2010-07-16 08:04:20 EDT
Sorry for the late reply, but I don't consider this bug having a high severity. It meets none of the criteria from https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity

Additionally, manually editing the config file and setting arbitrary options that cannot be set through the configuration dialog is not a supported use case.  

> Additional info:
> May somone post this bug on lxde bug tracker, beacause I couldn't post it
> myself.    

Why not? It even allows anonymous submissions.

I think if you really consider this a bug, you should file it yourself in the LXDE tracker. Usually I forward bug reports on behalf of Fedora users, but I cannot do this if I'm not convinced it is a bug.
Comment 2 Christoph Wickert 2011-03-06 14:43:44 EST
I still don't think this is a supported usecase but the problem was setting arbitrary options in the config file. If you think it this bug should get investigated, please report it to sf.net and put the URL of the bug report there in the URL field of this bug report.
Comment 3 Christoph Wickert 2012-06-10 19:07:18 EDT
Reopening, this was fixed in 0.5.10.
Comment 4 Fedora Update System 2012-06-10 19:39:28 EDT
lxpanel-0.5.9-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lxpanel-0.5.9-1.fc17
Comment 5 Fedora Update System 2012-06-10 19:40:51 EDT
lxpanel-0.5.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lxpanel-0.5.10-1.fc16
Comment 6 Fedora Update System 2012-06-11 20:30:27 EDT
Package lxpanel-0.5.10-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.5.10-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9267/lxpanel-0.5.10-1.fc16
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-19 20:19:25 EDT
lxpanel-0.5.10-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-06-27 23:51:41 EDT
lxpanel-0.5.10-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.