Bug 606141 - No devel headers for procps
No devel headers for procps
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Görig
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 766792
  Show dependency treegraph
 
Reported: 2010-06-20 17:13 EDT by Hicham HAOUARI
Modified: 2011-12-12 11:06 EST (History)
1 user (show)

See Also:
Fixed In Version: procps-3.2.8-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 766792 (view as bug list)
Environment:
Last Closed: 2010-11-01 16:59:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
procps.spec (24.17 KB, text/plain)
2010-06-20 17:37 EDT, Hicham HAOUARI
no flags Details

  None (edit)
Description Hicham HAOUARI 2010-06-20 17:13:52 EDT
Description of problem:
Packages who need to link against libproc have no way to do it on fedora since there are no headers for that. Debian provides a development packages for libproc

Version-Release number of selected component (if applicable):
procps-3.2.8-7.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1.Try to build a package against system libproc
2.No headers ! you can't compile it !
  
Actual results:
no procps-devel package

Expected results:
procps-devel package

Additional info :
i had to modify the spec and rebuild to be able to compile a package
Comment 1 Hicham HAOUARI 2010-06-20 17:37:36 EDT
Created attachment 425487 [details]
procps.spec
Comment 2 Fedora Update System 2010-10-19 04:05:49 EDT
procps-3.2.8-14.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/procps-3.2.8-14.fc14
Comment 3 Fedora Update System 2010-10-19 23:08:10 EDT
procps-3.2.8-14.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update procps'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/procps-3.2.8-14.fc14
Comment 4 Fedora Update System 2010-11-01 16:59:48 EDT
procps-3.2.8-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.