Bug 606168 - Evolution calendar does not update when subscribed MS exchange calendar is changed elsewhere
Evolution calendar does not update when subscribed MS exchange calendar is ch...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-20 20:34 EDT by srh
Modified: 2010-09-15 10:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 10:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 629603 None None None Never

  None (edit)
Description srh 2010-06-20 20:34:08 EDT
Description of problem:
Successfully set up Evo 2.30 on two different computers (PC1 and PC2) to connect to MS exchange account. 

Start up Evo on PC1, and make some calendar appointments on the exchange calendar. Close Evo on PC1. 

Start up Evo on PC2, see the appointments made by PC1, then add some more calendar appointments to the exchange calendar. Close Evo on PC2.

Start up Evo on PC1 again. See the first appointments in the exchange calendar made originally by PC1, but do NOT see the newer appointments made by PC2.

Close Evo on PC1. On PC1, open 'System Monitor', find and end/kill the 'e-calendar-factory' process. Start Evo on PC1, go to calendar (e-calendar-factory process starts up again), and now successfully see the appointments made by PC1 originally and the newer appointments made by PC2.

Note - closing Evo does not seem to always close 'e-calendar-factory' (used elsewhere?? eg. appointments/tasks on gnome panel clock?), and when Evo starts up again, if 'e-calendar-factory' is already running, then e-calendar-factory does not go to check if the exchange calendar has changed since Evo was last run. Killing e-calendar-factory forces it to refresh the exchange calendar when Evo starts up again.

Note - the same effect applies to Tasks on the exchange account.

Note - Not known if this issue occurs when Evo is left running on PC1 the whole time, while exchange calendar is changed via PC2. At the very least, each time Evo starts up, e-calendar-factory should refresh exchange calendar and tasks irrespective of whether e-calendar-factory is already running on any PC. Perhaps e-calendar-factory should also be doing regular update checks??

Version-Release number of selected component (if applicable):
Name       : evolution
Arch       : x86_64
Version    : 2.30.1
Release    : 8.fc13

Name       : evolution-exchange
Arch       : x86_64
Version    : 2.30.1
Release    : 3.fc13


How reproducible:
Pretty often. Always, if following the set of circumstances listed above (as far as I can tell).

Actual results:
No calendar refresh.

Expected results:
Exchange calendar should refresh often, or at least when Evo starts up, even if e-calendar-factory is already running.
Comment 1 Milan Crha 2010-09-15 10:16:32 EDT
Thanks for a bug report. I was pointed to this bug report from an upstream bug [1], thus I'm closing this one in favour of it (also because this is not fedora specific issue). I'm writing some explanation there, thus feel free to comment there as well.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=629603

Note You need to log in before you can comment on or make changes to this bug.