Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 606258 - Both shift keys for keyboard layout switching doesn't work correctly
Both shift keys for keyboard layout switching doesn't work correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 05:10 EDT by Jaroslav Škarvada
Modified: 2010-07-08 06:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 06:27:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2010-06-21 05:10:39 EDT
Description of problem:
If keyboard layout switcher is configured to "both shift keys", holding one shift (left or right) for a while causes layout switching.

Version-Release number of selected component (if applicable):
control-center-1:2.30.1-2.fc13

How reproducible:
Always for me, tested on one machine, all accounts including newly created.

Steps to Reproduce:
1. Add czech keyboard layout (CZE). 
2. Change keyboard layout switcher to "both shift keys".
3. Hold left or right shift for a while.
  
Actual results:
The keyboard starts rapidly switching between USA, CZE layouts.

Expected results:
Nothing happens.

Additional info:
Pushing both shift keys together works as expected. Holding both shift keys together for a while also causes rapid layout switching.

cat /etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
# This file is autogenerated by system-setup-keyboard. Any 
# modifications will be lost.

Section "InputClass"
	Identifier	"system-setup-keyboard"
	MatchIsKeyboard	"on"
	Option		"XkbModel"	"pc105+inet"
	Option		"XkbLayout"	"us"
	Option		"XkbVariant"	"(null)"
	Option		"XkbOptions"	"terminate:ctrl_alt_bksp,"
EndSection

This issue is very annoying because it renders the shift key unusable in this configuration.
Comment 1 Jaroslav Škarvada 2010-07-08 06:27:30 EDT
Today after installing regular updates it seems that it is working again ;)

Note You need to log in before you can comment on or make changes to this bug.