Bug 60626 - Qemm8 +Loadlin 6.1 cause core dump in Xconfigurator 4.4.3-1
Qemm8 +Loadlin 6.1 cause core dump in Xconfigurator 4.4.3-1
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-03-03 02:45 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-03 22:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdb output of Xconfigurator core dump (2.10 KB, text/plain)
2002-03-03 22:08 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-03-03 02:45:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i486)

Description of problem:
Xconfigurator dumps core with "illegal instruction" when RH7.0 is booted with
Loadlin 6.1from MSDOS 5.0 running Qemm 8. It works fine when booted with RH7.0
boot disk, or when booted with MSDOS 5 boot disk and Loadlin 6.1 is run from
command prompt.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:

I have Linux installed on its own drive (hdb), and boot to a DOS /Win3.11 drive
The machine is question was upgraded from RH 6.0 to 7.0 and working fine. One
day X Windows wouldn't start (dumped core.) I ran Xconfigurator, and it crashed
also. I tried to run xf86config, but the resulting XF86Config file didn't work
because of "no mouse." I re-installed (Custom Upgrade} all the XFree rpms from
the RH CD. Now Xwindows would start, but Xconfigurator continued to crash. When
trying xf86cfg, I noticed that there was a "ghost image" of my MSDOS screen.
Since my MSDOS drive isn't mounted, I assumed there must be something strange
going on with the video memory.
Comment 1 Need Real Name 2002-03-03 22:08:11 EST
Created attachment 47281 [details]
gdb output of Xconfigurator core dump
Comment 2 Mike A. Harris 2002-03-04 21:36:32 EST
It appears that either your hardware is faulty, or your installation is

At any rate, we do not support LOADLIN, so if the problem is not reproduceable
without loadlin by using supported booting/installation methods, then it
is outside of the scope of what we support.

Illegal instruction does not indicate a software bug generally, but data
corruption.  QEMM could be causing this perhaps.
Comment 3 Need Real Name 2002-03-05 00:14:44 EST
Thanks for the insights. I'll "play" with Qemm, although Linux is so much fun, I
may never need it again.

Note You need to log in before you can comment on or make changes to this bug.