Bug 606264 - Ping caused guest abnormally quit after changing virtio_nic MTU
Ping caused guest abnormally quit after changing virtio_nic MTU
Status: CLOSED DUPLICATE of bug 610343
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-06-21 05:32 EDT by Amos Kong
Modified: 2015-05-24 20:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-12 09:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amos Kong 2010-06-21 05:32:30 EDT
Description of problem:
I booted up a guest with virtio nic, change the MTU of guest nic and tap device
to 65520(max MTU of virtio nic), and added an arp entry on host, then ping
guest from host, but guest abnormally quit. Qemu outputted : "virtio-net truncating packet"

# ping $guest_ip -I virtio_0_6001 -s 65492 -M do
PING 10.66.84.205 (10.66.84.205) from 10.66.85.217 virtio_0_6001: 65492(65520) bytes of data.
ping: sendmsg: No such device
ping: sendmsg: No such device
ping: sendmsg: No such device
ping: sendmsg: No such device
ping: sendmsg: No such device
ping: sendmsg: No such device


Version-Release number of selected component (if applicable):
host kernel: 2.6.18-203.el5
guest kernel: 2.6.9-89.28.ELsmp
# rpm -qa |grep kvm
etherboot-zroms-kvm-5.4.4-13.el5
kvm-qemu-img-83-183.el5
kmod-kvm-83-183.el5
kvm-83-183.el5
kvm-tools-83-183.el5
kvm-debuginfo-83-183.el5

How reproducible:
100%

Steps to Reproduce:
1. Boot up a rhel4 guest with virtio nic
2. Change MTU of guest nic and $tap
guest)# ifconfig eth0 mtu 65520
host)# ifconfig $tap mut 65520
3. Add a arp entry on host
# arp -s $guest_ip $guest_mac -i $tap
4. Ping guest from host  (65520-28=65492, 65520 is max mtu of virtio nic)
#ping $guest_ip -I $tap -s 65492 -M do

 
Actual results:
host can ping guest successfully

Expected results:
guest abnormally quit

Additional info:
1. Command line:
# qemu-kvm -name 'vm1' -monitor tcp:0:6001,server,nowait -drive file=/root/autotest/client/tests/kvm/images/RHEL-4.8-64-virtio.qcow2,if=virtio,cache=none,boot=on -net nic,vlan=0,model=virtio,macaddr=02:70:04:52:e8:e2 -net tap,vlan=0,ifname=virtio_0_6001,script=/root/autotest/client/tests/kvm/scripts/qemu-ifup-switch,downscript=no -m 4096 -smp 2 -soundhw ac97 -vnc :0 -spice port=8000,disable-ticketing -serial unix:/tmp/serial-20100621-161808-MXgd,server,nowait -no-hpet
Comment 1 Michael S. Tsirkin 2010-09-05 13:54:27 EDT
I think this is the same issue as bz 610343: qemu
exiting on packet truncation.
https://bugzilla.redhat.com/show_bug.cgi?id=610343

Please check with kvm-83-164.el5_5.21
Comment 3 Michael S. Tsirkin 2010-09-12 09:00:20 EDT

*** This bug has been marked as a duplicate of bug 610343 ***

Note You need to log in before you can comment on or make changes to this bug.