Bug 606279 - Segmentation fault and Aborted occurred when start rhel4u8_64bit with spice
Segmentation fault and Aborted occurred when start rhel4u8_64bit with spice
Status: CLOSED DUPLICATE of bug 600205
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-21 06:33 EDT by Golita Yue
Modified: 2010-11-11 14:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 07:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Golita Yue 2010-06-21 06:33:24 EDT
Description of problem:
Segmentation fault (core dumped) and Aborted (core dumped) occurred when start rhel4u8_64bit with spice

Segmentation fault:
(gdb) bt
#0  0x00007fb634066e8b in memcpy () from /lib64/libc.so.6
#1  0x00007fb6352a8ea3 in quic_usr_more_lines_unstable (usr=0x7fb62f3a5680, 
    out_lines=0x7fb62f362e78) at /usr/include/bits/string3.h:52
#2  0x00007fb6352fadf2 in quic_encode (quic=0x7fb41c0008c0, 
    type=QUIC_IMAGE_TYPE_RGB32, width=720, height=16, line=0x0, 
    num_lines=<value optimized out>, stride=2880, io_ptr=0x7fb41c01fba0, 
    num_io_words=16384) at /usr/src/spice-common/quic.c:1282
#3  0x00007fb6352ac5e0 in red_quic_compress_image (
    display_channel=0x7fb41c00a4a0, dest=0x7fb41c00daec, src=0x7fb41c0065b2, 
    o_comp_data=0x7fb62f362fa0) at red_worker.c:5491
#4  0x00007fb6352b37c3 in red_compress_image (display_channel=0x7fb41c00a4a0, 
    in_bitmap=<value optimized out>, drawable=0x7fb62f3a0758)
    at red_worker.c:5571
#5  fill_bits (display_channel=0x7fb41c00a4a0, 
    in_bitmap=<value optimized out>, drawable=0x7fb62f3a0758)
    at red_worker.c:5672
#6  0x00007fb6352b3f07 in red_send_qxl_drawable (worker=<value optimized out>, 
    display_channel=0x7fb41c00a4a0, item=0x7fb62f3a0758) at red_worker.c:5859
#7  0x00007fb6352b4f37 in send_qxl_drawable (worker=<value optimized out>)
    at red_worker.c:6344
#8  display_channel_push (worker=<value optimized out>) at red_worker.c:6786
#9  0x00007fb6352b96be in red_push (arg=<value optimized out>)
    at red_worker.c:6913
#10 red_worker_main (arg=<value optimized out>) at red_worker.c:8506
#11 0x00007fb635536761 in start_thread () from /lib64/libpthread.so.0
#12 0x00007fb6340c44fd in clone () from /lib64/libc.so.6

Aborted:
(gdb) bt
#0  0x00007fccceb5a9c5 in raise () from /lib64/libc.so.6
#1  0x00007fccceb5c1a5 in abort () from /lib64/libc.so.6
#2  0x000000000047194e in _qxl_get_info (d=0x7069, info=0x7069)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:255
#3  0x00007fcccfde0053 in ?? () from /usr/lib64/libspice-server.so.0
#4  0x0000000000471c35 in qxl_reset (d=0x4e717c0)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:552
#5  0x0000000000473467 in qxl_display_resize (ds=0x2672f60)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:825
#6  0x0000000000443c87 in dpy_resize (opaque=0x4e71a58)
    at /usr/src/debug/qemu-kvm-0.12.1.2/console.h:218
#7  vga_draw_graphic (opaque=0x4e71a58)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/vga.c:1726
#8  vga_update_display (opaque=0x4e71a58)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/vga.c:1938
#9  0x0000000000473355 in qxl_display_refresh (ds=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/hw/qxl.c:835
#10 0x000000000040b64e in dpy_refresh (opaque=0x2672f60)
    at /usr/src/debug/qemu-kvm-0.12.1.2/console.h:236
#11 gui_update (opaque=0x2672f60) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:3302
#12 0x000000000040b0d8 in qemu_run_timers (timeout=1000)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:1183
#13 main_loop_wait (timeout=1000) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4117
---Type <return> to continue, or q <return> to quit---
#14 0x00000000004280fa in kvm_main_loop ()
    at /usr/src/debug/qemu-kvm-0.12.1.2/qemu-kvm.c:2127
#15 0x000000000040df1b in main_loop (argc=<value optimized out>, 
    argv=<value optimized out>, envp=<value optimized out>)
    at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:4290
#16 main (argc=<value optimized out>, argv=<value optimized out>, 
    envp=<value optimized out>) at /usr/src/debug/qemu-kvm-0.12.1.2/vl.c:6422

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.77.el6.x86_64
kernel 2.6.32-36.el6.x86_64l 
VM:rhel4u8_64bit

How reproducible:
100%

Steps to Reproduce:
1. start VM
/usr/libexec/qemu-kvm -cpu qemu64,+x2apic -smp 1 -m 8G -rtc-td-hack -no-kvm-pit-reinjection -balloon none -drive file=/dev/sdb,media=disk,cache=none,format=qcow2,if=none,werror=stop,rerror=stop,id=drive-ide0-0-0 -device ide-drive,bus=ide.0,drive=drive-ide0-0-0,id=ide0-0-0 -device virtio-net-pci,netdev=hostnet0,mac=00:23:55:2a:12:66,bus=pci.0,addr=0x4,id=hostnet0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -uuid `uuidgen` -boot c -spice port=5930,disable-ticketing -vga qxl
2. connect VM by spice
spicec IP_host 5930
  
Actual results:
Segmentation fault (core dumped) and Aborted (core dumped) occurred

Expected results:
no Segmentation fault (core dumped) and Aborted (core dumped)

Additional info:
tried VM=winXP,rhel6 and rhel5u5, ALL passed.
tried start rhel4u8_64bit + VNC, passed.
Comment 2 RHEL Product and Program Management 2010-06-21 07:03:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Gerd Hoffmann 2010-06-21 07:52:56 EDT

*** This bug has been marked as a duplicate of bug 600205 ***

Note You need to log in before you can comment on or make changes to this bug.